arturomf

Members
  • Content Count

    3
  • Joined

  • Last visited

  1. Hi all: I'm trying to integrate a register form into my phaser game. I have no problem with text input, radio or checkbox, but i have no idea of how implementing a combobox. Someone has implemented this succesfully? I need to show a country combobox. Thanks all!
  2. Thanks for the answer. All my audios are 44100Hz ogg , m4a and mp3 format. I have test with lower encoding rate but it's not a solution for me. As i said, sounds seems to be loaded and decoded correctly but there is no sound... I have only got some advance disabling web audio and playing audio after user input, but it only works using safari (not in my phonegap app) and only with sounds played in user input callback.
  3. Hi all: I'm new in community. I have been searching these great forums for a solution for days, but i had no luck. I'm developing a game with phaser (2.6.2) and all has been working until testing on ipad. I have no sounds at all, but all seems to be working ok. Sounds are working in all platforms except IOS (9.5.4). I have tested with a button on my game but it doesn't sound. It seems to be "running" but like muted... I have compiled game with phonegap and again, sound works in Android but not in IOS. All Audio Examples in https://phaser.io/examples don't work either. I have test it with mp3 file, m4a file, different bitrates but nothing works. I have been looking for a solution for days, but no one is working for me. I load sound in preload state function: game.load.audio('music_main_menu', ["assets/audio/m4a/menu_main.m4a", "assets/audio/ogg/menu_main.ogg"] this.sound = game.add.audio("music_main_menu"); and then, create a button in create function: button = game.add.button(game.world.centerX + 350, game.world.centerY + 150, 'btn_test_audio', this.actionOnClick, this, 2, 1, 0); Then, i have this in action click function: this.sound.play("",0,1,true); After loading it, that is what i see with game.sound.debugInfo on render (time is running): I'm debuuging Ipad remotely with Safari and there is no errors in console, and it is loading m4a file. Please, someone has lead with a similar problem and could help me? Thanks in advance.