Junior

Members
  • Content Count

    28
  • Joined

  • Last visited

  1. Hello JCPalmer, I have been away for a while but I would like to thank you for responding to my 'bug' report. I am glad that it is not a bug. I would also like to say thanks for the solution that you offered to solve the problem. There is however another issue that came up when I tried your solution: I was able to see the full scene (similar to picture # 4 above) in Firefox with all the materials and textures ). But when I viewed the scene in Chrome, Edge and Opera, they all looked like picture # 2 above with the texture still missing from the body of the car. The link to the scene is here Cheers.
  2. I am seeking help to solve this issue that has been a real challenge to me. I have a scene with an interactive car. The model was updated in Blender 2.78 and Blender exporter 5.1.2. The body, doors, hood, and trunk are separate meshes that use the same material. Everything seem to be okay when I view the scene in the sandbox. (All the meshes, materials and textures seem to be just right.) When I view the scene locally, a couple of the meshes will have the correct material and textures applied to them while they would be missing from other meshes that use the same material. When I view the scene live online, all the the textures will be missing. I have attached a couple of screen captures to explain what I mean. Here is the link to the online scene. Here is a link to the Babylon Scene and Blend File download. Note: I applied new materials to the meshes via the html file. I am not sure if this is an issue. The scene does not load in Firefox 50.1.0 The scene works in Google Chrome, Microsoft Edge and Opera.
  3. Hello Guys, thanks for your work with Babylon JS and Blender. I have tried the latest blender exporter (Version 5.1.0) but the problem with multiple meshes and animations has still not been resolved. I am not a programmer else I would try fix it my self, but I know that this was not an issue 2 years ago with earlier developments of Blender and Babylon JS version 2.2. I appreciate the time and effort that you take to make this framework a success and I would like to help make it better by testing it to report bugs or glitches. Two years ago, I created a test project that had multiple meshes and animations that actually worked. You can view the project here. (Click on the doors and hood to see the animations.) The *.babylon file for this project does not work with the current online version of the Sandbox. I am not sure if it is because of the file size (21 Megabytes) or that the framework has been completely rewritten since version 2.2. of Babylon JS. I would like to know however, if there will be a fix for the issue with multiple meshes and animations with the Blender exporter. How can I help to make it possible. Thanks for your effort.
  4. Hi Wingnut, I tried your suggestion but all the 5.0 versions of the Blender exporter give the same result. I also tried some of the older versions from the 4.0 to 4.6.1 and they all produce major errors. Thanks for your suggestion
  5. I have 3 meshes in a Blender scene. Each mesh has its own origin and animation. The meshes animate as expected when viewed in Blender, i.e. they move as distinct meshes and have their own distinct animation. When I export to Babylon JS and test it in the sandbox at "http://www.babylonjs.com/sandbox/", all meshes seem to share the same origin and all 3 animations are applied automatically to them. I am not sure if this a bug but I have tried exporting different animated meshes in the same scene from blender and I keep getting the same results. Could someone please give some advice on this. I am using Blender 2.78a and Babylon.js 5.0.6 exporter. Please find below the .blend and Babylon JS files. . Thanks 3 Mesh Animation.blend 3MeshAnimation.babylon
  6. Hello Ben, Smooth shading can be enabled by disabling 'no vertex sharing' in the 'Exporter Setting' under the Scene Property menu.
  7. Hi Guys, Thanks for your help with this one. I have found the solution to the problem. When setting up the constraints for the cameras in Blender, you have to use the constraint called 'Track To' and not 'Locked Track' as I have done. ArcRotate Cameras are now working correctly. Cheers
  8. Hi Guys, Sorry I was unable to respond to your request yesterday. Today, I have a link to two versions of the project with the *.blend and *.babylon files Here. Both versions are identical except for the 'active camera type'. One version has Free cameras while the other has ArcRotate cameras. The version with the Free cameras loads correctly, but the version with the ArcRotate cameras does not complete the loading process. Both versions have constraints setup in Blender. (Although I know it is not necessary for free cameras.) You can view them online for quick observation CarFreeCam and CarArcRotate Thanks to DeltaKosh for assisting me with the Control Panel. (He is an awesome Guy! ) . BTW, while I am on this subject, is there a way to make the transition between the different camera views more smoothly, i.e. fade in and out when I switch to a different camera. Thanks for your advice. CarArcRotate.zip
  9. Hello Guys, Just a quick observation. After exporting a scene from Blender, I recently discovered that the following 3 types of cameras prevent the Babylon.JS Scene from loading. AnaglyphArcRotateCamera ArcRotateCamera FollowCameraThis occurs when there is only a single camera in the scene and it happens to be one from the list. If other types of cameras are added to the scene, then the scene will load correctly even if the active camera is one from the list. I have searched the forum for a solution to this problem but could not find one. Is there a fix for this? Cheers
  10. Thanks, Triblade, I'll take you up on the offer soon. Cheers.
  11. @ JC Palmer, Thanks for the tip. I will give it a try. Cheers
  12. Hello Wingnut, Thanks for your explanations and words of advice. I know that what I am trying to achieve is a huge task, especially for a beginner. (There is a lot of things to learn and problems to solve.) Sometimes a bit of 'naivety' can take you to places that you never dreamed of . I would like to finish this project, therefore I am willing to take the challenge, and in the end 'collect my prize'. I appreciate your depth of thought and insightful suggestions as well as your broad scope of knowledge on the subjects involved. I will keep you updated on my progress over time.
  13. @ Stephen There are 3 requests. I realize that they are not easy to achieve but I will list them in priority order. Make 4 buttons so that users can view the car from 4 angles. Top, Front, Right, Left and Back Make 1 button so that users can see labels on the parts as illustrated here . (The user should be able to click on the labels to see a description or annotation of the parts.) Make 1 button so that a list of all the parts in the model can be generated and sent to a shopping cart for processing.If you are able to assist with any of the requests, then I would greatly appreciate it. Thanks
  14. Hi Guys, I am trying to create a user interface and I have started a thread on the forum here on Wednesday, Dec. 3, 2014. So far, no one has responded to my request for help. I find your discussion very interesting, and I would like know if you found a solution that you could share with me. I am not a programmer but I use blender a lot for creating 3D models. The project that I am currently working on is the development of an interactive 3D car Model that will allow the user to customize it and then press a button to automatically generate an invoice of all the parts in the model. Are you able to give any assistance? Cheers.