Search the Community

Showing results for tags 'ie'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • HTML5 Game Coding
    • News
    • Game Showcase
    • Facebook Instant Games
    • Coding and Game Design
  • Frameworks
    • Phaser 3
    • Phaser 2
    • Pixi.js
    • Babylon.js
    • Panda 2
    • melonJS
    • Haxe JS
    • Kiwi.js
  • General
    • General Talk
  • Business
    • Collaborations (un-paid)
    • Jobs (Hiring and Freelance)
    • Services Offered

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Twitter


Skype


Location


Interests

Found 17 results

  1. Vishal Akbari

    Unable to decode image in IE

    On refreshing in internet explorer png images are not decoded and assets are not loaded. Only when tab is reloaded, it works in fresh tab for the first time. It happens in PIXI 4.5.1
  2. We moved our game from Phaser 2.6.2 "Kore Springs" to 2.10.3 and encountered this error in Firefox and Internet Explorer: IndexSizeError: Index or size is negative or greater than the allowed amount The exception is trown from PIXI.Sprite.prototype._renderCanvas: renderSession.context.drawImage(this.texture.baseTexture.source, cx, cy, cw, ch, dx, dy, cw / resolution, ch / resolution); The arguments are: cx : 803 cy : 899.37 cw : 168 ch : 0 dx : -0 dy : -0.6299999999999955 resolution : 1 Everything was fine in "Kore Springs" but we wanted to take advantage of all the fixes and updates on tilemaps in CE.
  3. charlie_says

    PIXI sound & IE 11 Loader issue (Updated)

    Hi, I'm working on a game that may need to be playable on IE11 (ugh!) Having got my basic game now working, I've found that the sound is failing, with the error: Object doesn't support property or method 'addEventListener' It seems that pixi sound should work, but, it's not clear to me why this isn't happening for me... Any ideas?
  4. Hello everyone, First, this is my first message on this forum so I would like to say Hi to everybody and to thank you for the amazing answers I already found on it. I'm playing with PIXI v4 for a while now (some drawing + drag'n'drop tool) and find myself in trouble when I test my code on IE (not a big suprise I know...). Could someone tell me exactly what are the limitations of the PIXI Loader (the one extended from https://github.com/englercj/resource-loader) concerning IE11 ? because it doesn't seem to load resource as I'm getting empty textures on my canvas when I try to use a loaded resource. And if there are some big ilimitations, what you guys are doing as a workaround to support IE ? PS : I'm coding within an Angular (5) project, and can't find a way to debug Pixi's code on the console, hence my question on the forum Thank you in advance,, Guigzz
  5. Hey all! I add a music track that I want to loop using this code: music = new Phaser.Sound(game, "music", 1, true); It loops correctly everywhere except on IE. Has anyone has this issue? Is the work-around to have an event fire on sound complete?
  6. LucaDB

    Sprite as a mask problem

    Hi, this is my first post I'm trying to use an image (png) as a container mask, it seems to work well on macOS but on Windows 8.1/10 ( ie11, edge, firefox 53) mask has no effect. Here is the simple code var app = new PIXI.Application(window.innerWidth,window.innerHeight); document.body.appendChild(app.view); var baseContainer = new PIXI.Container(); app.stage.addChild(baseContainer); var theMask = PIXI.Sprite.fromImage('mask.png'); var baseImg = new PIXI.Sprite.fromImage('base.jpg'); baseContainer.addChild(baseImg); baseContainer.addChild(theMask); baseContainer.mask = theMask; I'm using PIXI 4.4.1 Any idea why this is not working? Thank you
  7. arcbox

    IE 11 IndexSizeError crash

    Hey everyone, So I'm testing a game on IE 11 in Canvas mode and I get the following error about every other time I refresh the page: SCRIPT5022: IndexSizeError File: phaser.min.js, Line: 12, Column: 1746 The phaser code at the problem location is: this.context.drawImage(a.texture.baseTexture.source,a.texture.frame.x,a.texture.frame.y,a.texture.frame.width,a.texture.frame.height,a.anchor.x*-a.texture.frame.width,a.anchor.y*-a.texture.frame.height,a.texture.frame.width,a.texture.frame.height) Sometimes I can load up the game fine, but if I refresh I get this error. Any ideas?
  8. if (game.input.mousePointer.isDown) {if (playerPower < maxPlayerPower)playerPower++;onMove = 1;} else if ((onMove == 1) && (game.input.mousePointer.isUp)) {onMove = 2;sprite.body.velocity.y += Math.round(Math.sin(sprite.rotation + 1 / 2 * Math.PI) * 1000) / 1000 * (-playerPower);sprite.body.velocity.x += Math.round(Math.cos(sprite.rotation + 1 / 2 * Math.PI) * 1000) / 1000 * (-playerPower);}Works on Chrome, doesn't on Internet Explorer 11. Maybe there is different method to use for IE? I'm using dev branch. Test live here : http://japiotr.pl/gravity-test/
  9. HI everybody. I'm using phaser 2.0.2 and I have an issue with I.E. When I load my game, I keep getting warning and error messages like "Phaser.Loader error loading file : 'foo' from URL 'fooUrl'"(Warning) and/or "Unable to set property "loaded" of undefined or null reference"(Error) Through some debugging, I've commented all the audio files and the game worked. However, when I was uncommenting the audios loader blocks to load it again, the error kept reappering. The issue also appeared when I loaded just some of the files and kept refreshing the page. Does anyone knows anything about it? Thanks in advance! Edit: The problem occurs in windows 7! In windows 8.1 is fine (don't know about windows 8)
  10. Hi, I've been having some problems with phaser in IE10, having worked around some unexpected behaviour I noticed some more problems. I was getting console errors reporting failed image requests although the browser network log shows successful image requests. Then I noticed some prior audio file request failures - fixing these and the image failures also went away. It turns out that the function fileError() is being called with the wrong index. At the time of the audio file failure, fileError is getting called with the current index of a subsequent file request, and not the index of the audio file. I put together a jsfiddle example to show this. It 1st requests a non-existant audio file, then it requests a number of image files. At the time the audio file load fails, it will be someway down the image file requests, so the actual fimage file it reports as failing will vary. I was initially using IE10, it looks like IE11 does it too, other browsers maybe, haven't tried. So, goto http://jsfiddle.net/stupot/84b6x7s4/, open the console, clear the cache and refresh, you'll see the image file error. Then comment out the 1st line in preload (beginning with game.load.audio) , clear the cache and hit reload - the image error has gone! Anyone care to have a crack at it
  11. Hi all, random problem here, wondering if anyone has had it - we're trying to develop a facebook game which consists of a Phaser app running in an iFrame. It all works great, but for some reason, the keyboard keys never register in IE10. We've tried ensuring the iFrame has focus, tried setting game.stage.disableVisibilityChange to false and to true, but cannot for the life of us figure out why the Phaser app can't control the keyboard from within an iFrame. Does anyone know if there's a way, maybe from the parent document, to allow Phaser to capture the keys? Thanks in advance, Nick
  12. viktov

    Bumpmapping

    Hi, Im using textures with normal map for bump mapping effect. And everything works fine on firefox and chrome but there is no visible result of bumpmapping in IE. Is it a known issue or am I missing something? The code I use: var scale = 10;var ceilingMaterial = new BABYLON.StandardMaterial("ceilingMaterial", scene);ceilingMaterial.diffuseTexture = new BABYLON.Texture("texture/ceiling.jpg", scene);ceilingMaterial.diffuseTexture.uScale = scale;ceilingMaterial.diffuseTexture.vScale = scale;ceilingMaterial.specularColor = new BABYLON.Color3(0.5, 0.5, 0.5);ceilingMaterial.bumpTexture = new BABYLON.Texture("texture/ceiling_normal.jpg", scene);ceilingMaterial.bumpTexture.uScale = scale;ceilingMaterial.bumpTexture.vScale = scale;
  13. hercules

    IE 9/10/11 sound file limit

    Hello everyone! I wonder if someone is facing this problem except me: IE has a (hardware dependent) limit of sound files that can be loaded via HTML5 Audio.load method. For me, it's exactly 41 sound file. When reaching this limit, IE fails to load sound with onerrror event firing on Audio element (I'm not making a testcase, hoping that it's a well-known bug, so many years it's there). So, what can be done with this? Sound sprites? Tried that one, every browser except IE is OK playing sound sprites, but in IE there are some problems (as always). What else? Thank you!
  14. yovo

    Trouble loading font in IE10

    hello i code a classic tap game based on the sample Whack a thing http://www.yovo.tk/projet/tap/ all good except on ie10 where i have a error Object doesn't support this property or method Column: 4File: renderer.js, Line: 13288, Column: 4 what is strange, (either life would be so easy), is that error is only throw when i'm online, on my local server it's work good ?! so i try to search the differences between servers, can't find anything, i finally found that trouble comes when font.fnt and/or font.png are loading any idea about what's wrong or what i do wrong ? o
  15. Hi guys, i have this strange behaviour with IE11 and i really have no idea what to do. When i try to launch my game (in Canvas Mode not WebGL) i cannot see nothing at all, no images, only the background color. The strange thing is that if i open the console log (F12) and refresh the page everything works perfectly! If i disable the console again and refresh here i got nothing at all again. It's a very strange behaviour and i really don't know what to do. Anyone got this kind of issue? I'm using the full-screen template and Phaser 1.1.6. Thanks.
  16. benny!

    Device class and msPointer

    Hi, the Device class by phaser (refer to line 339) sets the touch property to true on IE10, Windows7, because of the msPOinterEnabled property. if ('ontouchstart' in document.documentElement || window.navigator.msPointerEnabled) { this.touch = true; } This confuses me since no touch events are fired. As I can read in the msdn - our lovely friends from M$, fires pointer events instead of touch events. Besides, in my case, no pointer device is attached anyway, and only normal mouse events are triggered. So, my question is - is it correct to equalize pointer events with touch events? How do you guys handle pointer events? Thanks for any enlightenment ;-) Best, benny!
  17. rich

    IE11 to contain WebGL?

    Looking promising http://fremycompany.com/BG/2013/Internet-Explorer-11-rsquo-s-leaked-build-395/