Search the Community

Showing results for tags 'rpg maker mv'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • HTML5 Game Coding
    • News
    • Game Showcase
    • Facebook Instant Games
    • Coding and Game Design
  • Frameworks
    • Phaser 3
    • Phaser 2
    • Pixi.js
    • Babylon.js
    • Panda 2
    • melonJS
    • Haxe JS
    • Kiwi.js
  • General
    • General Talk
  • Business
    • Collaborations (un-paid)
    • Jobs (Hiring and Freelance)
    • Services Offered

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Twitter


Skype


Location


Interests

Found 2 results

  1. I want to play video by means of pixijs. This code below is ok in normal project. But if I put it in RPG Maker MV plugins, it can't play anything, or just play sound with still image. function test(){ app = new PIXI.Application({ width: 600, height: 600, backgroundColor : 0x1099bb, }); app.view.id = "test"; app.view.style.zIndex = 100; app.view.style.position = "absolute"; app.view.style.margin = "auto"; app.view.style.top = "0px"; app.view.style.left = "0px"; app.view.style.right = "0px"; app.view.style.bottom = "0px"; document.body.appendChild(app.view); var texture = PIXI.Texture.fromVideo('test.webm'); videoSprite = new PIXI.Sprite(texture); app.stage.addChild(videoSprite); }
  2. I am trying to write a plugin for RPG Maker MV, which uses Pixi.js. The problem may be an incompatibility, but I have asked several people now and I just don't know where else to ask. The PIXI Version I tried it on was 4.5.4 Kreaturen.Kampfsystem.StarteKampf = function () { // Kampf Übergang for (var i = 1; i <= Kreaturen.Kampfsystem.KampfÜbergang.AnzahlFrames; i++) { Kampf_Anfang.frames.push(PIXI.Texture.fromImage(Kreaturen.Kampfsystem.KampfÜbergang.Pfad + i + '.png')); } Kampf_Anfang.anim = new PIXI.extras.AnimatedSprite(Kampf_Anfang.frames); console.log(' Kampf_Anfang.anim: ', Kampf_Anfang.anim); Kampf_Anfang.anim.animationSpeed = 0.5; Kampf_Anfang.anim.loop = false; Kampf_Anfang.anim.gotoAndPlay(0); // force reset frame Kampf_Container.addChild(Kampf_Anfang.anim); SceneManager._scene.addChild(Kampf_Container); Kampf_Anfang.anim.onComplete = function() { console.log(88888) Kreaturen.Kampfsystem.KampfAktiv = true; } } Everything works fine, the picture gets displayed but the animation just doesn't play... And because of that the .onComplete function never triggers Does anybody have an idea why this may occur?