Search the Community

Showing results for tags 'warnings'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • HTML5 Game Coding
    • News
    • Game Showcase
    • Facebook Instant Games
    • Coding and Game Design
  • Frameworks
    • Phaser 3
    • Phaser 2
    • Pixi.js
    • Babylon.js
    • Panda 2
    • melonJS
    • Haxe JS
    • Kiwi.js
  • General
    • General Talk
  • Business
    • Collaborations (un-paid)
    • Jobs (Hiring and Freelance)
    • Services Offered

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Twitter


Skype


Location


Interests

Found 2 results

  1. Dear all: I'm here again with several FRAMEBUFFER errors I thought has been solved migrating to BJS 3.1. (please take a look to closed topic http://www.html5gamedevs.com/topic/35352-strange-problem-when-using-highlight-layers/) On dektop (Win10 64bit), FF Developer Edition (59.0b13 - 64-bit) shows these kind of WebGL console warnings (excerpt): Error: WebGL warning: clear: Framebuffer not complete. (status: 0x8cd6) COLOR_ATTACHMENT0 has no width or height babylon.3.1.custom.min.js:5:4633 Error: WebGL warning: clear: Framebuffer must be complete. babylon.3.1.custom.min.js:5:4633 Error: WebGL warning: drawElements: Framebuffer not complete. (status: 0x8cd6) COLOR_ATTACHMENT0 has no width or height babylon.3.1.custom.min.js:5:19516 Error: WebGL warning: drawElements: Framebuffer must be complete. babylon.3.1.custom.min.js:5:19516 Error: WebGL warning: drawElements: Active texture 0 for target 0x0de1 is 'incomplete', and will be rendered as RGBA(0,0,0,1), as per the GLES 2.0.24 $3.8.2: The dimensions of `level_base` are not all positive. Also on Win10, my Chrome browser (64.0.3282.186 - 64 bit) shows awful lines like these (excerpt again) : .Offscreen-For-WebGL-00000233101348E0]GL ERROR :GL_INVALID_FRAMEBUFFER_OPERATION : glClear: framebuffer incomplete .Offscreen-For-WebGL-00000233101348E0]GL ERROR :GL_INVALID_FRAMEBUFFER_OPERATION : glDrawElements: framebuffer incomplete .Offscreen-For-WebGL-00000233101348E0]RENDER WARNING: texture bound to texture unit 0 is not renderable. It maybe non-power-of-2 and have incompatible texture filtering Running Safari browser on macOSX (High Sierra) works OK. Tomorrow I'll look console outputs for WebGL warnings. Well I get all these warnings but, at least, the 3D contents are all (Win10 and High Sierra) shown as intended. The real problem comes when I load the code on Android Chrome (64.0.3282.137), as it renders black all my PBR textures, while showing the following lines through DevTools>Remote devices>Console (that is I'm debugging here mobile Chrome from desktop Chrome): [.Offscreen-For-WebGL-0xb917a020]RENDER WARNING: texture bound to texture unit 2 is not renderable. It maybe non-power-of-2 and have incompatible texture filtering. 85[.Offscreen-For-WebGL-0xb917a020]RENDER WARNING: texture bound to texture unit 3 is not renderable. It maybe non-power-of-2 and have incompatible texture filtering. 43[.Offscreen-For-WebGL-0xb917a020]RENDER WARNING: texture bound to texture unit 1 is not renderable. It maybe non-power-of-2 and have incompatible texture filtering. 42[.Offscreen-For-WebGL-0xb917a020]RENDER WARNING: texture bound to texture unit 4 is not renderable. It maybe non-power-of-2 and have incompatible texture filtering. 21[.Offscreen-For-WebGL-0xb917a020]RENDER WARNING: texture bound to texture unit 5 is not renderable. It maybe non-power-of-2 and have incompatible texture filtering. main.html#page-mixer:1 WebGL: too many errors, no more errors will be reported to the console for this context. Under Safari for iOS I get my models rendered as is expected. Tomorrow I'll be able to inspect console output. As said in the thread, all my textures are power of 2 (512x512). I can't reproduce this behavior on PG, as this is a really complex development. I welcome any suggestion about how to have my code clean of warnings and, mainly, about the way to have my PBR materials not being renderered black on Android Chrome. Best regards.
  2. MackeyK24

    SimpleMaterial WEBGL WARNINGS

    Has anyone else tried using the SimpleMaterial library class ? I can use it and it works but for some reason the browser is reporting WEBGL warnings when using material. Is weird ... there are NO custom uniforms or samplers (outside what was defines in Babylon.simpleMaterial.ts) Note: All other material library classes work just fine (except some funny showing really large fur when using furMaterial) @Sebavan ... Got any clue about this one?