Sign in to follow this  
sekao

Phaser chokes on a particular tile map

Recommended Posts

Hello. I am new to Phaser and the very first thing I wanted to try was loading tile maps. The first one I tried worked fine, but when I tried loading another one (without any code changes) I received the following error:

TypeError: map.tiles[tile.index] is undefinedphaser.js (line 70157, col 20)

I uploaded my project below and would love your help:

 

https://github.com/oakes/phaser-tile-map-error

Share this post


Link to post
Share on other sites

Hello!

 

I've been having the same problem too.  Did you manage to find an answer?

 

The only thing I can figure out with mine (and it seems really stupid) is that I get the same error when I rotate or flip one of my tiles. (I'm using Tiled to create my tilemaps.) If I create a map and don't do anything different with the tiles, it works just fine. But as soon as I flip one tile, I get the same error.

 

I don't know if this is helpful or not.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.