Vousk-prod.

BABYLON.Tools.CreateScreenshot does not render mesh instances

Recommended Posts

Hi everybody,

 

I've just noticed that BABYLON.Tools.CreateScreenshot does not render mesh instances in the output picture...

 

You can test here (pink object is simple box, isolated blue object is a mesh, the two other blue objects are instances of the isolated blue) :

 

http://www.babylonjs-playground.com/#1MYQJJ#13

 

Strange, isn't it ?

 

[EDIT: correct playground link and color info]

Share this post


Link to post
Share on other sites

Oh sorry, my bad, I didn't post the correct playground...

http://www.babylonjs-playground.com/#1MYQJJ#13

 

In fact the pink object is just an simple box, with no instances, just for checking.

 

The blue meshes are those which are instanciated : the isolated one is the original mesh, the two others are the instances.

 

When no instances are created, the screenshot is ok (we can see the pink ref box and the blue mesh), but when we start to create instances, no more blue objects on the screenshot...

Share this post


Link to post
Share on other sites

I click on the 'S' on my keyboard, but it does not work. Maybe this is due to Chrome or it does not work.

But I've look and yes, it's strange, instances are not visible it in the screenshot. there are like ghosts. A Bug?

 

Share this post


Link to post
Share on other sites

This does not seem resolved. It missing the 2 instance  cubes blue :

 

http://www.babylonjs-playground.com/#1MYQJJ#14

 

and this: not work:

scene.actionManager = new BABYLON.ActionManager(scene);scene.actionManager.registerAction(new BABYLON.ExecuteCodeAction({ trigger: BABYLON.ActionManager.OnKeyUpTrigger, parameter: "s" }, function () {             BABYLON.Tools.CreateScreenshot(engine, scene.activeCamera, { precision: 1 });   }));

The key 's' does not trigger anything (I'm in Chrome)

 

Share this post


Link to post
Share on other sites

It starts to download the screenshot on page loading because dad72 has changed the code to launch automaticaly the screenshot to test it. But the fact that chrome does not fire key press event is a real bug.

Is it chrome side or BJS side, that is the question.

Share this post


Link to post
Share on other sites

ooopps sorry, I was in FF

 

doesn't work in chromium : the png is downloaded but the S key doesn't show the pop-up

 

mmhh... inspecting the event listeners in chromium, it seems the keydown event listener is attached to some jquery callback function

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.