Bolko

Bad performance on IE

Recommended Posts

Hi,

 

my pixi project is much slower on IE. 

On chrome and FF everything runs supersmooth, IE lags.

Is that a common problem or do I have to consider specific things to make it run smoothly on IE?

 

Thanks

Share this post


Link to post
Share on other sites

Update your video drivers, because IE use drivers from system, (chrome has embedded drivers)

Seriously? So you guys don´t see a worse performance on IE 11 compared to Chrome and FF?

Share this post


Link to post
Share on other sites

Seriously? So you guys don´t see a worse performance on IE 11 compared to Chrome and FF?

In my company i test one game on standard PC width win7, and on chrome I see 60FPS but on IE about 15FPS, when I update video drivers performance on IE increase to 60FPS too... AND when I did stress-test I see performance on IE, on updated drivers is much better than chrome because chrome use embedded drivers...

Share this post


Link to post
Share on other sites

OK thanks guys, I´ll try updating my drivers.

 

OK, but in desktop you shouldn't see any performance problems anyway. Only if you have lots (and I mean really LOTS!) of objects to handle. I think you could do best with profiling your game. Chrome has some nice to do this job.

 

 It´s not really a lot of objects, but the whole project scales to fit the browser window. So in a small window it´s fine in IE as well, but in full HD it lags pretty much, although there´s not really much happening. Just a big background image and some masked graphics which are being animated.

Share this post


Link to post
Share on other sites

Hey guys, I installed a new driver but it didnt help.

But i realized the bad performance is because IE switches to software render mode:

 

WEBGL11258: Temporarily switching to software rendering to display webGL content

Pixi.js v2.2.9 - http://www.pixijs.com/

WEBGL11135: getContext: Context attribute premultipliedAlpha:false is not currently supported

 

I found others also have that problem: http://www.html5gamedevs.com/topic/2563-internet-explorer-11-webgl-bug/

 

Here it says this is fixed, but in v3 of pixi. Will this not be fixed in 2.2.9?

https://github.com/GoodBoyDigital/pixi.js/issues/1201

Share this post


Link to post
Share on other sites

hmm, ok, I´ll think about it ... or with this problem I´m almost forced to switch to V3.

Actually I decided to use 2.x because I thought it´s probably saver and more stable than v3 ... ironic, isn´t it ;)

Share this post


Link to post
Share on other sites

Hey Chad, I switched to v3 which wasnt too painful, but unfortunately the error in IE11 still comes up :(

 
WEBGL11258: Temporarily switching to software rendering to display webGL contentPixi.js 3.0.2 - WebGL - http://www.pixijs.com/WEBGL11135: getContext: Context attribute premultipliedAlpha:false is not currently supported

Share this post


Link to post
Share on other sites

We can't fix that error, that just literally means that the params you passed to create the webgl context are not supported (at least when it is in software render mode).

 

Did you try passing true for transparent when creating the renderer? Have you tried the Canvas renderer? Upgrading PIXI isn't going to change the options the browser supports :)

Share this post


Link to post
Share on other sites

Ok, but why does IE switch to software render mode

 

Likely because your gpu doesn't support webgl, IE doesn't support the necessary drivers for your gpu, IE determined for your machine that software rendering will work better, any of many different reasons. None of which have anything to do with pixi AFAIK.

Share this post


Link to post
Share on other sites

Yes

It means instead of using the GPU to run the shaders and things, it will use the CPU to run that stuff in an emulation environment.

Ok guys, so whom to believe? ;)

Well, would I gain performance when switching to canvas on IE11 then?

Share this post


Link to post
Share on other sites

You´re right, xerver, now I tested it with PIXI.CanvasRenderer and the thing has 60fps in fullHD, while having a max of 25 fps in WebGL mode.

Is there a way to detect if WebGL is supported so I could automatically switch to canvas?

I could monitor the fps and suggest the user to click a link pointing to a canvas version or what is the best practice here in your opinion?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.