Sign in to follow this  
LLS

I have trouble to loading texture of an object in Babylonjs SandBox

Recommended Posts

Hello to all.

I created an object in Blender and I applied the texture using UV coordinates.
This is the result of the render in Blender:
image.jpg
http://postimg.org/image/5tbxbzk1l/
Unfortunately, when I go to upload the files in the sandbox of Babylonjs this is the output:
image.jpg
http://postimg.org/image/4gu8a3mm1/
This is the log export file .babylon in Blender:
image.jpg
http://postimg.org/image/d8194d5x5/
 
Can someone please help me? Where am I wrong? Can you give me some suggestions.

Files that I put in the sandbox are these:
- casa_geografia.babylon
- casa_geografia.log
- layout_diffuse_texture.png

 
I attach them here.
 
Thanks in advance.

Casa.zip

Blender_Model_Casa.zip

Share this post


Link to post
Share on other sites

Hi LLS, welcome to the forum.  Sorry to hear you are having issues.  I have no answers, but, if possible, could you include the .blend file in the zip, too.  Thanks.

Hi Wingnut. Thank you for the warm welcome.

I attach the blender file in the bottom of the topic.

Share this post


Link to post
Share on other sites

Hi LLs, welcome to BJS.

 

In Blender in the Edit Mode for your object, Select all the vertices then Mesh -> Normals -> Recalculate Outside. Then rexport.

 

cheers, gryff :)

 

Yes_It_Works.jpg

Thank you. It works . I think the problem was that I first exported the model in OBJ and then I imported it into Blender . Anyway thank you very much . You 've solved a big problem!  :D  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.