Sign in to follow this  
Allen

Some IOS device Sprite get blur

Recommended Posts

Hi,

 

I wonder why when I use some of IOS device open the phaser game, the sprite displaying on the background will get blur. The resolytion of the source sprite I used 1080 *1080. Normally it shouldn't get blur on any of ios devices?

Share this post


Link to post
Share on other sites

all IOS devices are retina, if the blur is only a slight blur its do with the upscaling. You can set the resolution within Phaser, you'll need to match it to the device, which for iOS devices is 2 (even for the big 6+), I think some other devices are even running at a pixel density of around 3 so the blur will be worse there.

Of course, if you're accidentally using some sort of blur filter then that could be the culprit but if its only a fairly little 'fuzziness' it'll be the resolution thang.

My laptop is retina and even in 2016 I still see this regularly on the web, some images 'hide' the upscaling better than others, if your backdrop has crisp lines and sharp colours contrasts then it'll be much more visible than your average photographic image.

Share this post


Link to post
Share on other sites
22 hours ago, mattstyles said:

all IOS devices are retina, if the blur is only a slight blur its do with the upscaling. You can set the resolution within Phaser, you'll need to match it to the device, which for iOS devices is 2 (even for the big 6+), I think some other devices are even running at a pixel density of around 3 so the blur will be worse there.

Of course, if you're accidentally using some sort of blur filter then that could be the culprit but if its only a fairly little 'fuzziness' it'll be the resolution thang.

My laptop is retina and even in 2016 I still see this regularly on the web, some images 'hide' the upscaling better than others, if your backdrop has crisp lines and sharp colours contrasts then it'll be much more visible than your average photographic image.

Thank you very much. The issue is only happen on some ios devices which I tested. The weird thing is that even for two same models (iphone6), the sprite in one device will get but in other won't. 

Share this post


Link to post
Share on other sites

Try taking a cloth to the screen and cleaning it! After my young daughters and their sticky fingers have massacred my phone I can barely see anything!

Ha, no sorry, I'm out of ideas, when stuff works in one environment and does not in another that should be identical there could be a multitude of things wrong.

Got any screenshots from the phone?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.