Sign in to follow this  
jstoone

Weird offset bettween Graphics and DisplacementSprite

Recommended Posts

Hi

I am using a displacement map to distort three graphics lines. And since the lines have a speed, I need to move the displacement space at the same speed as the points, which define the lines. I do this, so that the line keeps it shape, and doesn't "wave" around. But it seems like there is an offset in the speeds at which they move, mostly at lower speeds, which makes the line change a bit of its shape.

Is there a better way to achieve this effect, or is there some local/global positioning I'm overseeing with Pixi.js?
Would It make sense to move the PIXI.Graphics themselves instead?

Here is a simplified version of my project:
https://jsfiddle.net/adL8wqwv/1/

There is also some jittering, which I'm unsure if is caused by missing antialiasing or something else... If any of you can spot how to smoothen out the graphics I'd be very happy. But the displacment + graphics offset mentioned above is my main priority so far.

Feel free to ask any questions, if something needs to be clarified.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.