Sign in to follow this  
jonteferm

Sprite appears more blurry at some positions than it does on others

Recommended Posts

I have a graphics issue that I cannot pinpoint. My sprite appears more blurry at some positions of the map. Does anyone have an idea what this kind of problem can depend on? Both of these pictures shows the sprite when idle on different positions - so no animation is playing - and at the first picture the sprite looks more clear than it does on the second one. I don't know what more information I can give on this that is relevant.

Difference2.thumb.png.7c93dba5d9802e546d9e790ffd297e2d.png

 

Share this post


Link to post
Share on other sites
8 hours ago, Arcanorum said:

What is the size of the game window, and do you have anti-aliasing disabled?

If you think this is a Phaser specific problem, then you should ask in the Phaser sub-forum.

512 * 512 is the size of the game window and no I don't think I have that disabled because it isn't something I do in the code. Is it enabled by default? Yes that is true, but I thought maybe it is a more global issue.

Share this post


Link to post
Share on other sites

I think I've encountered something like this before, can't remember. Trying to narrow it down.

You could try disabling anti-aliasing with this. The false sets whether anti-aliasing should be used.

var game = new Phaser.Game(width, height, Phaser.AUTO, '', null, undefined, false);

Can you make a playable version somewhere so we can try it ourselves? Might be something with your device.

Share this post


Link to post
Share on other sites
26 minutes ago, Arcanorum said:

I think I've encountered something like this before, can't remember. Trying to narrow it down.

You could try disabling anti-aliasing with this. The false sets whether anti-aliasing should be used.


var game = new Phaser.Game(width, height, Phaser.AUTO, '', null, undefined, false);

Can you make a playable version somewhere so we can try it ourselves? Might be something with your device.

Aah thanks! Disabling the anti-aliasing definitely did the trick.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.