Sign in to follow this  
AhmedMohamed

[SOLVED] Loaded Dudes do not collide with each other

Recommended Posts

Hello,  need a little help here :)
I have a scene where I load a dude and clone many versions of him (about 20). I enable collisions on them,  on a tank in the scene, and also on the ground. collisions work as expected when I order the dudes to moveWithCollision until they hit the wall, and also when they move towards the tank. But : Dudes do not collide with each other, when they come close, they merge and become a single dude. I tried modifying the ellipsoid and ellipsoid offset , made them much more bigger and still the same effect. I tried also creating a bounding box , making it a child of dude , and moving it with collisions instead, but things didn't go so well also.

This is my demo (compressed) - tried to use the playground , loading assets from the github repo url but it didn't work.
https://github.com/AhmedFathiShaban/webgl/blob/master/Demo.rar

I also tried using this function  Temechon provided here to visualize the ellipsoid  , and whatever the size I make of the ellipsoid they finally merge with each other, I see the ellipsoids merge without the slightest objection :)

Pleasetell me the best practice in this situation, I am sure I am not the first to try to load multiple dudes with collision :D 

Thanks in advance :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.