Exa

png texture compression on iOS devices

Recommended Posts

Hi everyone,

I have an issue with texture compression on iOS device : here is the problem :

on my PC :59ea03b5c0edb_versionpc.thumb.jpg.f93d8853751d5cf470cb0e751e5debb3.jpg

on my iPad : version-ipad.thumb.jpg.cef252837e8713fa96d0aaac5e1195ca.jpg

the material :         

		{
			"customType" : "BABYLON.PBRMaterial",
			"directIntensity" : 1,
			"emissiveIntensity" : 1,
			"environmentIntensity" : 0.9,
			"specularIntensity" : 1,
			"cameraExposure" : 1,
			"cameraContrast" : 2,
			"microSurface" : 0.5,
			"overloadedShadowIntensity" : 1,
			"overloadedShadeIntensity" : 1,
			"overloadedAmbientIntensity" : 0,
			"overloadedAlbedoIntensity" : 0,
			"overloadedReflectivityIntensity" : 0,
			"overloadedEmissiveIntensity" : 0,
			"overloadedAmbient" : [
				0,
				0,
				0
			],
			"overloadedAlbedo" : [
				0,
				0,
				0
			],
			"overloadedReflectivity" : [
				0,
				0,
				0
			],
			"overloadedEmissive" : [
				0,
				0,
				0
			],
			"overloadedReflection" : [
				0,
				0,
				0
			],
			"overloadedMicroSurface" : 0,
			"overloadedMicroSurfaceIntensity" : 0,
			"overloadedReflectionIntensity" : 0,
			"albedoTexture" : null,
			"ambientTexture" : null,
			"opacityTexture" : null,
			"reflectionTexture" : null,
			"emissiveTexture" : null,
			"reflectivityTexture" : null,
			"bumpTexture" : null,
			"lightmapTexture" : {
				"name" : "CleanedUp_BedroomLightmap-3_comp_light.png",
				"level" : 1,
				"hasAlpha" : false,
				"getAlphaFromRGB" : false,
				"coordinatesMode" : 0,
				"isCube" : false,
				"uOffset" : 0,
				"vOffset" : 0,
				"uScale" : 1.002394,
				"vScale" : 1.002394,
				"uAng" : 0,
				"vAng" : 0,
				"wAng" : 0,
				"wrapU" : 1,
				"wrapV" : 1,
				"coordinatesIndex" : 1,
				"isRenderTarget" : false,
				"renderTargetSize" : 0,
				"mirrorPlane" : null,
				"renderList" : null,
				"animations" : null,
				"extensions" : null
			},
			"useLightmapAsShadowmap" : true,
			"refractionTexture" : null,
			"ambient" : [
				1,
				1,
				1
			],
			"albedo" : [
				1,
				1,
				1,
				1
			],
			"reflectivity" : [
				0,
				0,
				0
			],
			"reflection" : [
				0,
				0,
				0
			],
			"emissive" : [
				0,
				0,
				0,
				1
			],
			"roughness" : 1,
			"useRoughnessFromMetallicTextureAlpha" : false,
			"useRoughnessFromMetallicTextureGreen" : false,
			"useAlphaFromAlbedoTexture" : false,
			"useEmissiveAsIllumination" : true,
			"useMicroSurfaceFromReflectivityMapAlpha" : false,
			"useSpecularOverAlpha" : true,
			"useRadianceOverAlpha" : true,
			"indexOfRefraction" : 0,
			"invertRefractionY" : false,
			"emissiveFresnelParameters" : null,
			"opacityFresnelParameters" : null,
			"disableLighting" : false,
			"name" : "MUR",
			"id" : "39e75ac7-f7b5-4d06-98a0-50fb26b52378",
			"backFaceCulling" : true,
			"wireframe" : false,
			"alpha" : 1,
			"alphaMode" : 2
		}

the lightmap texture : CleanedUp_BedroomLightmap-3_comp_light.thumb.png.47e43be2a862a7b6f151e94e1e799395.png

 

I tried to compress with pvr format, to merge lightmaps with a white layer and use it as png, or jpg, and in albedo channel but nothing worked, any advices?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.