Sign in to follow this  
b10b

Stock Car Hero

Recommended Posts

With NASCAR schedule in full-swing we just released "STOCK CAR HERO" - a retro pseudo-3d racing game (inspired by SEGA's "Daytona USA" and "Outrun").  We included road courses (as well as the famous ovals) - so some turning-right is needed!

icon.png.ec423aec5b558ca5978d9c1a2220c684.png

Play for free in your browser (no adverts): http://b10b.com/stockcarhero

"Compete across North America as you race in the Stock Car Series. Dodge traffic, boost around banked corners, collect coins and upgrade your car for the next race. Are you the Stock Car Hero?"

screenshot_03.jpg.3a92000ee630a1dcd15250f9c315ab12.jpgscreenshot_06.jpg.76adf4fdafb76bb3dfb840cf10de064e.jpg

Technical:

Like our other games STOCK CAR HERO was developed with Haxe + awe6 + CreateJS and designed to run on any device at ~30fps - which can be a challenge when dealing with pseudo-3D (no WebGL here, just lots of sprites!).  STOCK CAR HERO is based on our GRAND PRIX HERO engine and includes a few new touches.  The game uses tilt-to-steer on supporting mobile devices - that feature is on Chrome's 2018 deprecated list (for insecure domains).

Commercial:

STOCK CAR HERO is available to license (on a non-exclusive basis) from our website: http://b10b.com

Share this post


Link to post
Share on other sites

@totor thanks so much for the feedback and performance issue.  The biggest difference (over GRAND PRIX HERO) is the horizon tilting (rotation) and double buffering needed to keep the horizon stable.  I noticed yesterday that a few mobile devices were getting bogged down with this rotation when 'context2d.imageSmoothingEnabled' was enabled.  I disabled imageSmoothing across all "mobile", and based on your feedback also put in additional performance checks to disable effects for lower-end "desktops" too.  On my benchmarks today I'm getting ~tolerable FPS on my (old) S3 across GRAND PRIX HERO and STOCK CAR HERO (with the latter featuring more scenery and more effects).  On all modern devices I'm getting clean 30FPS.

Please can you try again and report back?  There's a debug message displayed bottom left when the game is paused.  Latest version is >= 1.0.60 (a hard refresh may be needed) and the last two numbers (e.g. "80 | 1200") tell me about the device's graphical performance.  Please could you share your (old) laptop's numbers?  Thanks :)

Share this post


Link to post
Share on other sites

congrats, that fixed it!
the report says v1.0.62 31fps 0.64-700
i got the nice sensation of speed, the visual effects of the boost is very effective and you get all the sensations and feelings
of the arcade drive, nice job.

Share this post


Link to post
Share on other sites
4 hours ago, totor said:

congrats, that fixed it!
the report says v1.0.62 31fps 0.64-700
i got the nice sensation of speed, the visual effects of the boost is very effective and you get all the sensations and feelings
of the arcade drive, nice job.

Thanks for checking back and validating for me!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.