wumingqyl

Load gltf display exceptions

Recommended Posts

Correct:

image.png.66056da4154aceb3419f30fbc13f1a76.png

use babylon viewer .It looks like a occlusion problem.Did I forget what? No answer was found in the document.

Thanks to anyone

let viewer = new BabylonViewer.DefaultViewer(domElement, {
scene: {
antialiasing: true,
assetsRootURL:'./'
},
lab: {
defaultRenderingPipelines: {
bloomEnabled: true,
bloomThreshold: 1.0,
fxaaEnabled: true,
bloomWeight: 0.2
}
},
model: {
url:"./mode/shafa1.glb"
},
templates: {
loadingScreen: {
params: {
backgroundColor: "#aaa",
loadingImage: "./logo.png"
}
}
}
});

image.thumb.png.b58c2b63a024df8de65163de2214ff0f.png

image.thumb.png.ad4f048d0ca938be0bddde40ed5e438b.png

Share this post


Link to post
Share on other sites

I believe I am familiar with this problem.

Manually open your GLTF file and set

"alphaMode":"OPAQUE"

(search for alphaMode and set to that value)

That should fix the issue.
If you are exporting from 3ds Studio Max ensure that your textures are not using alpha mode which is set automatically every time you load a png, even if it has no transparency.

Hope it helps :)

Share this post


Link to post
Share on other sites
On 2018/7/28 at PM2点48分, Rodrix3 said:

我相信我熟悉这个问题。

手动打开您的GLTF文件并进行设置

“alphaMode”: “不透明”

(搜索alphaMode并设置为该值)

这应该解决问题。
如果从3ds Studio Max导出,请确保纹理不使用每次加载png时自动设置的alpha模式,即使它没有透明度。

希望能帮助到你 :)

Thank you very much. I checked gltf, you are right. This is the default setting for Marmoset Toolbag to export gltf.

Share this post


Link to post
Share on other sites
1 hour ago, wumingqyl said:

Thank you very much. I checked gltf, you are right. This is the default setting for Marmoset Toolbag to export gltf.

I am glad I helped! I struggled myself and a lot with this issue until I discovered how to fix it!

Success on your project ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.