Sign in to follow this  
Dan K

Suggestion for me.Rendererable.isKinematic name change

Recommended Posts

I think you should change the property isKinematic to "blockEvents" to embody the scope and purpose of this variable.  I know its linked collisions and I suspect that's why it was chosen.  But even if the programmer is looking at the collisions aspect of the Renderable, I think the blockEvents will catch their eye and their mind will consider 'collisionEvents' blocked by the changing of this term.

Share this post


Link to post
Share on other sites

thanks for the feedback, but coming from the Unity word, isKinematic is kind of well know as they define the same property. Now admittedly the use of isKinematic has been slightly abused in melonJS to also apply to pointer event as well (if this is what you mean), where it should be limited to physic interactions/motions.

Share this post


Link to post
Share on other sites

If it was limited to those physic interactions then I agree... The name seems appropriate... But the fact that it blocked the events surprised me.  However, it was in the documentation so that is on me of course (like there's anyone else to blame...🤣)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.