Sign in to follow this  
JECKL

pixi-spine antialias

Recommended Posts

Hello, I am a Korean developer.

I play animation through pixi-spine.

The problem is, I want to turn off anti-aliasing because my spine is low resolution

 When you false antilias to an option on canvas,

other objects look like pixels, but spines don't.

What should I do?

Even if the translation is unstable, please understand.

Share this post


Link to post
Share on other sites

Edges are inside texture, so its actually texture filtering that you are fighting.

Two ways, global and local:

//global setting, EXECUTE BEFORE EVERYTHING

PIXI.settings.SCALE_MODE = PIXI.SCALE_MODES.NEAREST;

//alternative: one particular spine object
resources['myspine'].spineAtlas.pages[0].baseTexture.scaleMode = PIXI.SCALE_MODES.NEAREST;

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.