ZYandu

Webgl uniform1iv error on IOS with Cordova

Recommended Posts

I am getting this error in my game only on IOS with Cordova on PIXI 5.1.1 with Webgl 2.0 (It works on Google Chrome perfectly fine). All my sprites and graphics get loaded to the screen but when the RAF should start it gets this error and doesn't continue. https://imgur.com/a/lqVDzdA

Maybe it's something my IOS with Cordova is lacking from the requirements for Webgl 2.0 Specifications? https://www.khronos.org/registry/webgl/specs/latest/2.0/#3.4

Thanks for any advice! 🙂

Share this post


Link to post
Share on other sites

Would you happen to know what type of PIXI texture uses Webgl 2.0's uniform1iv call? I would love to just be able to remove something than to completely revert back to PIXI v4 🙂 

Share this post


Link to post
Share on other sites

what type of PIXI texture uses Webgl 2.0's uniform1iv call

Oh, right, its not your shader, its pixi problem. uniform1iv is used even in webgl1 for samplers.

I think its not about integers. I think its something about MAX_TEXTURES. Whats the minimal demo that fails? Just a bunch of sprites?

Share this post


Link to post
Share on other sites

The game looks like this: https://imgur.com/a/Y4B2OYT

Everything looks like it got displayed fine to start, but it doesn't start the RAF due to the uniform1iv error. Everything on screen are sprites, graphics, and bitmap texts.

Once the RAF starts I use some pixi-particles emitters and interpolate sprites and graphics x position values but they aren't even .visible yet. ^.^

Hope this helps! 😁

Share this post


Link to post
Share on other sites

The only pixi plugin I use is pixi-particles: https://github.com/pixijs/pixi-particles.

If I run my game on IOS with the actual Safari app, pixi's console log is showing me that it reverted to webgl 1 and my game does successfully start the RAF. https://imgur.com/a/wDCwmMw 

So it might be something to do with Cordova's webkit 2 specifically that doesn't like the pixi texture locations allowed as you were saying. ^.^

Share this post


Link to post
Share on other sites

Yes I was using ParticleContainer. Unfortunately, making them all into normal Containers still gives me the same uniform1iv error.

I just fixed a bug with my audio playing code that was actually the cause for the RAF not starting. Now my game runs the RAF on IOS Cordova so at least the error isn't stopping my game. ^.^

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.