rich

Please help test Phaser 2.0.3 (would really appreciate it!)

Recommended Posts

Hi all,

 

I've just pushed up a new build package for Phaser 2.0.3 which I would really really like you all to test in your current games.

 

You can get the build files from here: https://github.com/photonstorm/phaser/tree/dev/build

 

It contains 2 important changes:

 

1) Now using Pixi 1.5.2 internally

 

2) Using a modified State update core loop. The State.update method is now called BEFORE any other sub-system (see this thread here: https://github.com/photonstorm/phaser/issues/661)

 

It's change number 2 that is the most important to test on the widest range of games. So even if your game is finished, so long as it used Phaser 2.x I would really appreciate you dropping the new build file in and testing if the game works ok. If it does then PLEASE post about it here. And of course if it doesn't please post here too! You don't have to explain in detail what breaks, just a short summary will suffice.

 

Thanks everyone.

 

Cheers,

 

Rich

Share this post


Link to post
Share on other sites

I tried my game CargoBlaster with the new code and it seems to not change the state properly. The preload bar loads all the way and then it just sits there. Maybe I'm not calling something properly, but in Phaser 2.0.2, it worked perfectly. You can view/debug the game here:

 

http://simplypixelated.com/static/CargoBlaster/CargoBlasterPhDev/

 

There are no errors in the console, so I'm not sure what is wrong.

Share this post


Link to post
Share on other sites

My arcade physics stopped working for the most part, although I have it set up in a temporary weird and worrysome way when I was having issues with Arcade physics and groups at a time (though it still worked fine in 2.0.2).

 

It seems like the only physics check still working is relating to enemies which are groups held in an array.  Here's my collision code in the update:

this.game.physics.arcade.collide(g_wall, g_player, null, null, this);        // *****This still works******        for (var i = 0; i < g_enemy.length; i++)  {            this.game.physics.arcade.collide(g_wall, g_enemy[i], null, null, this);            this.game.physics.arcade.overlap(g_player, g_enemy[i], this.entityOverlap, null, this);        }        //****************************        this.game.physics.arcade.overlap(g_player, g_door, this.door_overlapped, null, this);

g_sprite is a group containing all groups/entities (for Z axis sorting).

g_player extends Phaser.Group containing multiple sprites.

g_enemy also extends Phaser.Group, set like this, where g_enemy is just an array:

            switch (object_string.slice(0, (object_string.length - 3)) ) {                case "enemy":                    map.obj['p' + pad(i, 2)] = new EnemyCharacter(map.room_data[i][1], i, map.room_data[i][2], map.room_data[i][3]);                    map.obj['p' + pad(i, 2)].name = object_string;                    g_enemy[i] = map.obj['p' + pad(i, 2)];                    g_sprite.add(g_enemy[i]);                    break;            }

Also for some reason my character is running around at double the speed he was before.  Here's the movement code:
 

if (game.left_key.isDown && this.entity.body.velocity.x > -this.entity.speed && this.entity.e.allowMovement) {        this.entity.body.velocity.x = -this.entity.speed;    }

Share this post


Link to post
Share on other sites

I tried my game CargoBlaster with the new code and it seems to not change the state properly. The preload bar loads all the way and then it just sits there. Maybe I'm not calling something properly, but in Phaser 2.0.2, it worked perfectly. You can view/debug the game here:

 

Can I just confirm - if you swap the phaser.js 2.0.3 file for the 2.0.2 one available from the site, does it work fine? I.e. literally just swapping to 2.0.3 breaks it?

 

It's entirely possible this is the case, I just need to be crystal clear - if enough other people report similar results then I simply can't keep the state change update.

Share this post


Link to post
Share on other sites

I´m afraid  my game doesnt load with this version either. It doesnt have anything to do with  sound since I commented all the lines of code sound related. It just doesnt load.

With 2.0.2. everything was working fine.

:(

These is the error I get:

 

Uncaught SyntaxError: Unexpected token <

  1. Uncaught ReferenceError: Phaser is not defined

Share this post


Link to post
Share on other sites

Sorry to be a pain but could you share the dropbox folder with me? (send it via PM if you like :) so I can download it and run it locally. I think the error is happening because phaser.min.js hasn't finished downloading before your anonymous function in index.html has run. If you were to wrap that in a window.onload or a DOMContentLoaded I reckon it'd probably be ok.

Share this post


Link to post
Share on other sites

@LeonardoDigital: You have a bunch of html in your phaser.min.js file. I'm assuming you copied it wrong or something. Or maybe it has something to do with dropbox. Did you right click the file on github and click save as? Because that doesn't work on github. I've done that a few times myself :P You have to either clone the repo or open the file completely and then copy and paste the raw output into a file.

Share this post


Link to post
Share on other sites

Just tested 2.0.3 on my game. After fixing bug with sound loading everything works perfectly (state management also).

 

Unfortunetely I didn't see any perfomance boost with new Pixi. I was hoped for few extra fps :) But thats fine.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.