HappinessSam

Weird Firefox problem with the webgl renderer.

Recommended Posts

I was working on a project on Friday. I left it and went away for the weekend. When I came back today and went to test the project it was running at 3 fps having changed nothing. Before this test my Firefox had just updated to a new version, 21. It still runs fine in Chrome, and runs faster on my iphone 3gs than on firefox in desktop.

 

I did honestly assume that I'd messed something up myself but I couldn't pin anything down. I started stripping things out until I literally had an empty project running at 3fps. I then on a whim forced Pixi to choose the canvas renderer and it went back up to 60 fps. This makes it look like there's something going on with the webgl renderer.

 

Obviously this can't be the reason, because the run pixi run demo performs fine on Firefox, so I was hoping someone else might have an idea. To illustrate I created two skeleton project with minimal code. The only difference is that one autodetects and uses the webgl, the other uses the canvas renderer.

 

The canvas renderer version, runs at 60fps for me on Firefox 21

The autodetect -> webgl version that runs at 4fps

 

Is anyone else seeing the same thing, and if so any idea what I'm doing wrong? Could it be my graphics card? I have tried updating the driver but it's the most recent version.

 

The code for these pages is this, with the renderer line commented out to taste:

 

var Main = (function () {    function Main() {        this.stage = new PIXI.Stage(0xFF023200, true);        //this.renderer = new PIXI.CanvasRenderer(400, 600);        this.renderer = PIXI.autoDetectRenderer(400, 600);        document.getElementById("content").appendChild(this.renderer.view);        this.stats = new Stats();        document.body.appendChild(this.stats.domElement);        this.stats.domElement.style.position = "absolute";        this.stats.domElement.style.right = "0px";        this.stats.domElement.style.bottom = "0px";        window["requestAnimFrame"](this.animate.bind(this));    }    Main.prototype.animate = function () {        window["requestAnimFrame"](this.animate.bind(this));        this.stats.begin();        // render the stage        this.renderer.render(this.stage);        this.stats.end();    };    return Main;})();window.onload = function () {    var gm = new Main();};

 

 

Share this post


Link to post
Share on other sites

Just to update that I did manage to fix it by reinstalling my graphics card drivers.

 

I have a ATI Mobility Radeon HD 5400, and both windows and the ati control center were telling me my driver was up to date. It seems like the new version of firefox just looked at my driver and card and decided to disable direct2d.

Share this post


Link to post
Share on other sites

Yes, completely back to normal.

 

I did talk about the issue on another forum and I wasn't the only person to see it - someone else also had firefox disable direct2d when they updated to version 22, though they only noticed when I asked them to look. Also running on a laptop, but his was an integrated graphics chip.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.