ForgeableSum

Members
  • Content Count

    595
  • Joined

  • Last visited

  • Days Won

    2

Everything posted by ForgeableSum

  1. We're looking for someone to convert our very large inventory of multiplayer html5 games to mobile. Qualified candidates: Experience/knowledge of the mobile market, including how to get approved in various app stores Technical proficiency in Cordova or other frameworks designed to make the conversion easy (we're open to using anything, as long as it works and meets our quality standards) Experience with UI / game design as lots of gameplay elements and UI need to be adopted for mobile, and in some cases, completely redone Example of a game you'll be converting: http://starve.io/ If you succeed with the first project we're definitely interested in a full hire or more contract work. If interested, please email chris@addictinggames.com with the subject being "MOBILE CONVERSION APPLICATION." Please include your past experience and / or resume / relevant work you've done.
  2. Nope. But I think I may have solved it - if you play the game and collide with asteroid while you have a shield on . Let me know if it seems like "normal collision behavior."
  3. Hmm, because I tried rect-rect and it still had the problem.
  4. A pretty glaring problem really, and easily reproducible. My physics bodies appear to stick to each other on collide. That's two moving bodies, both with some velocity, and 1 of which is immovable. You can see it yourself by playing my game, activating a shield and flying into an asteroid: http://booster.space I've tried the following: * changing the bounce values on both bodies (tried .5, ,1, etc) * set stopVelocityOnCollide to false on both bodies * switching between circular physics bodies and rectangular physics bodies No luck. It seems, no matter what I do, the ship won't bounce off the asteroid like a normal physics collision would do. Instead, the ship sticks to it. It's extremely frustrating for players (and I am one of them). Using Phaser 2.6.2.
  5. Fun little side project. Took me literally 3 days. Let me know what you think! http://booster.space
  6. Do what I did: don't put it in a state, or in a game input event at all. Simply attach it to a click event on the body or html elements using jQuery. you know the user is going to click body or html eventually. Sucks that i can no longer auto-play intro music. On the other hand, I completely understand why Google implemented this as spammers take advantage of auto-play.
  7. With jQuery: $('html,body').on('click', function() { if (!inGame) { if (game != undefined) { game.sound.context.resume(); } } });
  8. Yes, Phaser. Also, a major patch released yesterday with some new units and gameplay overhauls: https://feudalwars.net/devblog/v110-patch-notes
  9. Thanks all! I just added hold position (H key) and stop (S key).
  10. Okay, i just ran an interesting test. If I remove ALL updates to graphics objects, the stutter is gone. But if I leave in even a single update (e.g. drawing a single rect and clearing it every tick), the problem is just as bad as drawing hundreds of rects. Again we're talking about drawing a single rectangle to a single graphic. And the stutter is monstrous! If I set all graphics to not visible, the problem goes away (regardless of how much I update them). I also tried limiting the number of graphicsData pushed to 10 (to assure it wasn't the quantity of graphics data) and it had no effect.
  11. Also, if I remove 2/3rd of all the graphics activity i outlined above (e.g. disable unit circle and healthbar updates), the problem persists). It seems like having any small quantity of graphics updates causes the problem. It also happens if I remove updates to the mini map. So it's like the mere existence of graphics causes the problem.
  12. It's about 40 rectangles to one graphics object (the healthbars), 20 circles (unit circles underneath) to a separate graphics object and another 20 rectangles to a separate graphics object (the mini map) all at around the same time. All in all, it doesn't seem like that much. I'm doing the same graphics stuff in strike tactics and it never gives a stutter problem.
  13. Debugging chrome-specific issues would be a whole lot easier if the Chrome releases "blog" wasn't such a mess. Jesus Christ Google, just give me a bullet list. Look at this mess: https://chromereleases.googleblog.com/ You expect better from Google. It seems there is no easy way to determine what updates were released and when.
  14. curiously enough, firefox does not have the problem.
  15. i've confirmed that it is not a polyfill / conflict as none of my libraries have changed. i also tried disabling other libraries - the problem is still there. It seems no matter what I do, updating graphics at any frequency will cause PIXI.WebGLGraphicsData.prototype.upload to hang. It's very unpredictable but when it does happen, it happens every 20 seconds or so. Float32Array and Uint16Array are culprits - but i don't know what to do with that information, other than removing any updates to graphics in my game (which is not really an option).
  16. I'd rather not say publicly and make it easier for cheaters to understand my code. But like I said, I don't see how it's relevant as the problem occurs before or after compiling into a single JS file. How is it relevant?
  17. I'm not sure what you mean by "build." I'm using Phaser 2.6.2. Sure I compile my source code into a single JS file for deployment, but that seems irrelevant to the problem as it happens using a single js file (minified source code) or multiple (unminified).
  18. Thanks for the reply. Since "babel poyfills" aren't called directly in Phaser, how would I go about disabling them? As far as I can tell, I'm not using any polys. Only rectangles and circles (but mostly rectangles). So if I'm not using polys, where and how are poly fills taking place? Excuse the ignorance, but I very rarely poke around in pixi source code.
  19. I just can't account for it. It happens on every machine. I'm not doing all that much with graphics and when I try to disable any updating of graphics, the stutter is still there. It's as-if the very existence of graphics in my game causes the problem. Already posted this issue on the Phaser forum and didn't get anywhere. I'd appreciate any insight.
  20. And yes, it makes no sense. I've dismantled my game dozens of times now trying to find the cause. I'm beginning to question reality. I can't sleep at night!
  21. 2.6.2 though I've tested it and found the bug appearing in the latest community edition.