Jump to content

SenPie

Members
  • Content Count

    14
  • Joined

  • Last visited

  1. I wanted to make this post, because I had an issue with upgrading pixi.js from 5.1.1 to latest version, which currently is version 6.0.4. I am using TypeScript for my project, and when I updated the version for pixi I got many strange errors, which were not that easy to debug from logs and I struggled to fix. Here the log: https://pastebin.ubuntu.com/p/NXpXMGrzym/ Just if you look in release changes list between those versions, there were many typing changes, hot fixes, and even a whole project dedicated to fixing typing in pixi.js. Full list: https://github.com/pixijs/pixijs/releases. F
  2. Hey @ivan.popelyshev do you use telegram, discord or any other program that would make communication faster?
  3. I am using tsify to compile the typescript, and I have no idea how to specify the typescript version to be 3.9.5. Can you share your usual tsconfig.json file which you would use in pixi v6 projects?
  4. I followed your advice from previous post and fixed the typings, however there are many more other issues when compiling the code. Here is the full log: https://pastebin.com/SPUcsLcU. Here is my tsconfig.json and packages in package.json file { "compilerOptions": { "target": "es6", "lib": ["es2015","dom"], "module": "commonjs", "typeRoots" : [ "./typings", "./node_modules/@types"], "noImplicitAny": false, "strictFunctionTypes": true, "alwaysStrict": true , "resolveJsonModule": true, "esModuleInterop": true }, "exclude": ["./templates"] } "depend
  5. Then returning to the previous post can you please help me to upgrade my project to pixi.js v6 😅
  6. Hi, I want to use pixi-viewport library in my project, however I get this TypeScript errors when I try to integrate it in my project [15:57:08] [TypeScript error: node_modules/pixi-viewport/index.d.ts(2,13): Error TS1005: '=' expected.] { fileName: 'node_modules/pixi-viewport/index.d.ts', line: 2, column: 13 } [15:57:08] [TypeScript error: node_modules/pixi-viewport/index.d.ts(2,36): Error TS1005: ';' expected.] { fileName: 'node_modules/pixi-viewport/index.d.ts', line: 2, column: 36 } [15:57:08] [TypeScript error: node_modules/pixi-viewport/index.d.ts(3,13): Error TS1005:
  7. I think right now the best for me is to switch back, and after version 6.1.0 gets available I will again try to upgrade the pixi verison. Thanks
  8. Thanks will do that. However the the same issue is present in other places like this one Also, what without issue was compiling before now is giving this huge error list in terminal https://pastebin.ubuntu.com/p/NXpXMGrzym/
  9. Hi, My project is using 5.1.1 version of Pixi.js, however I decided to upgrade it to version 6.0.4, which presumably is the latest one and is also the version that I am most comfortable with. Unfortunately, after upgrading the version I get many errors from TypeScript, which does not recognize most of the classes like PIXI.Spritesheet, PIXI.Texture and etc. It says namespcae "PIXI" has no exported member 'Texture'. Here is my tsconfig.json { "compilerOptions": { "target": "es6", "lib": ["es2015", "dom"], "module": "commonjs", "typeRoots": ["./typings", "./node_modules/@
  10. hey, just reposted my question there as an issue https://github.com/eXponenta/pixi5-playables-boilerplate/issues/12 I hope project is not dead, because I just started making playables and would love to contribute to this project along with my work, if I could get a bit of help:D
  11. Yes, it worked! and you saved me a lot of debugging time. Thank you!
  12. Let me know if you need any additional info. Btw, here is the full screenshot
  13. Hi, I just cloned the repo in my local, did npm install and then run gulp command from cmd. Server started with this log: C:\Users\user\js\pixi5-playables-boilerplate>gulp [17:43:02] Using gulpfile ~\Documents\projects\js\pixi5-playables-boilerplate\gulpfile.js [17:43:02] Starting 'default'... [17:43:02] Starting server... [17:43:02] ==Watch== [17:43:02] Dev app started http://localhost:8080 [17:43:02] LiveReload started on port 35729 [17:43:02] Running server then when I visited http://localhost:8080/templates/debug/index.html to see the live version of the project I get this e
  14. 2021-06-25 14-18-28.mkv Hi, I've made a fragment shader that bends and stretches a given texture to give it a fluid flow. Here is the code: #ifdef GL_ES #define LOWP lowp precision mediump float; #else #define LOWP #endif uniform sampler2D u_texture; varying LOWP vec4 v_color; varying vec2 vTextureCoord; uniform float u_time; uniform sampler2D uSampler; vec4 normalizedSin(float speed, vec4 var, vec4 outputValue) { return ((sin(var * 3.14159 * speed) + 1.0) / 2.0); } float sphereMaskNode(float hardness, float radius, vec2 center, vec2 uv, float outputValue) { return 1.0
×
×
  • Create New...