Sign in to follow this  
moszis

mouse events not detected when dragging sprite

Recommended Posts

I'm having a strange issue, I have not encountered before.   When dragging a sprite over another sprite, mouse events underneath dragged sprite are not firing.

 

For example if I have a SpriteA, which has mouseover event.  If I simply drag my mouse over it, event would work just fine.   However, if i'm dragging another sprite (SpriteB) over SpriteA, mouseover event of SpriteA is not detected.

 

I know I have done this before where it worked, but I cant figure out whats going on right now.  Is there some setting that allows a sprite to be "click-through" ?

 

Thank you!

 

 

Edit:  Just in case it makes a difference, some additional information:   I am dragging an "item" from one item slot to another.  Both item and each slot is a sprite.  When dragging an item, I need to know over which slot its currently positioned to know where to move it.   Similarly this could be handled on mouseup event, but strangely mouseup event is firing for ORIGINAL slot, not the slot that mouse is hovering over.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.