Mighty editor local development

Recommended Posts



here is how I use it:

* if on windows - download - git for windows - https://msysgit.github.io/ and install it

* download nodejs - https://nodejs.org/ and install it
* open git bash
* execute following commands:

cd /c/users/your_user_namegit clone https://github.com/TheMightyFingers/mightyeditor.gitcd mightyeditor./startdev

open google chrome and go to http://localhost:8080


** you can also want to edit config file- located at: server/config-dev.js

Share this post

Link to post
Share on other sites

installation requires internet. If you need offline installation:
* download: nodejs - https://nodejs.org/ 

* download git bash - https://msysgit.github.io/

* download fontforge - https://github.com/fontforge/fontforge/releases

* download mightyeditor - https://github.com/TheMightyFingers/mightyeditor/archive/master.zip

* save downloaded files on the usb drive.

* install nodejs and git bash on offline computer 

* extract master.zip - e.g. C:\users\your_user_name\mightyeditor

* edit server/config-dev.js - to fit your system

* open git bash

* execute:

cd /c/users/your_user_name/mightyeditor./startdev

Share this post

Link to post
Share on other sites

Thanks so much! Two more things 1.Do I need to be on github clone the repo? and does gitbash come with git for Windows or is separate?

imo - you don't need an account to clone repo  - why don't you try out? :)

Git bash is a part of git for windows 


And what do I need to edit config-dev. js for? Sorry if I sound dumb I'm a noob

If fonts isn't working - you might need to change fontforge to full path

you can change host and port also there.

Share this post

Link to post
Share on other sites

I have setup the mightyeditor in my system, but I encountered a problem,

when I click userdata in the editor page,

it shows "Uncaught TypeError: Cannot set property length of #<CSSStyleDeclaration> which has only a getter",

so I cannot add or edit userdata, did I miss something in the installation?


Trace back to the editor source code as follows: (:8080/MT/ui/InputHelper.js:85)


inheritStyle: function(){
   var bounds = this.el.getBoundingClientRect();
   var style = window.getComputedStyle(this.el);
   for(var i in style){
      this.input.style = style;                                                <-- this line causes the problem
ps. I am using up-to-date chrome browser.
and sorry for my pool english.

Share this post

Link to post
Share on other sites

help ME:(


$ ./startdev
2015-10-16 15:53:25:  Starting server { root: '../client',
  host: '',
  port: 8080,
  shutdownTimeout: 3,
  index: 'index.html',
  prefix: 'p',
  servers: { p: 'tools.mightyfingers.com' },
  projectsPath: '../client/data/projects',
  buildDir: '../client/data/build',
  dbName: '.db.json',
   { from: 'info@mightyfingers.com',
     auth: { user: 'info@mightyfingers.com', pass: '********' } },
  tools: { fontforge: 'fontforge', mobile: '/home/kaspars/compile' },
  auth: { sessionLifeTime: 604800000, hashRounds: 12 } }
2015-10-16 15:53:25:  { [Error: Cannot find module 'nodemailer'] code: 'MODULE_NOT_FOUND' } SERVER SHUTDOWN
stack trace
Error: Cannot find module 'nodemailer'
    at Function.Module._resolveFilename (module.js:337:15)
    at Function.Module._load (module.js:287:25)
    at Module.require (module.js:366:17)
    at require (module.js:385:17)
    at Object.MT.plugins.Postman (C:\users\dka\mightyeditor\server\plugins\Postman.js:5:16)
    at Object.<anonymous> (C:\users\dka\mightyeditor\server\Server.js:23:18)
    at Module._compile (module.js:435:26)
    at Object.Module._extensions..js (module.js:442:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:311:12)

Share this post

Link to post
Share on other sites



projects are located in the:

You can copy/rename project folder or move to another computer.




ME project link contains ID: {project_id}/{revision_name} 
revision name by default is 0

Share this post

Link to post
Share on other sites

Yeah I did that. If I click on "Source Editor" I can see my written code, browse through the folders and everything - but in the map editor I just have a blank screen. So no assets will show up, no objects are created etc... just a blank screen like a new created project :/

Share this post

Link to post
Share on other sites

map is stored in the:


I just have verified that you can copy projects and everything should work fine.

Be aware that you need to turn off nodejs ( server ) if you are overwriting existing project - otherwise server can rewrite newly copied files any time.


You can call your project any name you wish instead of hash - e.g. RacingGame ( instead of p2555 )


and then navigate to the: http://localhost:8080/#RacingGame

Share this post

Link to post
Share on other sites

aaaand some other issues. I wanted to give windows another try, so I cloned my instance. When I use Chrome for DEV chrome takes ALL my RAM (and I mean ALL of it! All 16GB!). Another Problem: fontforge, I installed it but when I want to add a font it just says:

 ERROR: exec fontforge { [Error: Command failed: C:\Windows\system32\cmd.exe /s /c "fontforge -script info.pe
 The command "fontforge" could not be found (<-- hand translated from german, somethink like this in english)

Share this post

Link to post
Share on other sites

Wow, I thought it was bad when chrome sucked dry my 4gb ram.

I haven't tried in a while as I got scared away by the ram requirements on my older ultrabook, but I had more luck memory wise on Firefox.

On some windows versions I believe chrome has may have some leak problems, not sure where the fault may lie though.

But in my brief test Firefox didn't have the same problem.

Share this post

Link to post
Share on other sites

it's no problem using chrome on linux. runs fine. but on windows it causes these ram problems. I use Opera now for dev on windows and maybe git for my projects to switch easier between win and linux. but the font-forge problem still remains. I can see from the error, that I need to have fontforge in my PATH for executing command-line stuff. But I'm not sure if a "special" font-forge setup is needed for windows. I just googled it and took the first setup I got.

Share this post

Link to post
Share on other sites

I already tried my best, 4 hours of work yet I still dont get it, how do I use mighty editor offline??

I already installed node.js, cloned the mightyeditor from github, tried all the command lines at git prompt thing.

I'm getting crazy already !!


Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.