Sign in to follow this  
phil1234

no vertex sharing ?

Recommended Posts

Hi,

 

I been struggling to find out why babylon exporter was creating flat shaded meshes by default until I found that option hidden in the scene window wich is probably the least used window in blender ui (been uising it for decades now)

 

I mean why on earth would anyone need to ruin a mesh with such an option ? I been writing exporters and using game engines for years now with blender, this is the most AWKWARD option I have ever seen

 

if at least it was not enabled by default

 

regards

Share this post


Link to post
Share on other sites

The ability to save the export options as part of the .blend file facilitates a growing set of options that can be used, without requiring someone to remember what options were used the last time.  For the scene panel choice, my first choice was World.  I had noticed in the export source that it was checking for the existence of World though.  It seems someone had been building .blend files outside of Blender.  Did not want to break anyone.  Scene was best of Render, Scene, & Render Layers.  It is documented. https://github.com/BabylonJS/Extensions/tree/master/TowerOfBabel

 

The option itself, did not originally set a different normal when checked.  The function was changed as a result of this thread: http://www.html5gamedevs.com/topic/16579-black-gradient-marks-on-mesh/?hl=%2Bblender+%2Bvertex+%2Bsharing#entry93969  .  That is where the default is changed to true.  Looking at the screen shot in the documentation, it is false.  I would support changing it back to false.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.