Sign in to follow this  
jsdream

Why I am getting 40 fps instead of 60 fps even on very simple scene?

Recommended Posts

Hello everyone!

I was looking for the answers across forum topics but without success.  :unsure: 

I am just wondering why when I am viewing any babylon.js app (even as simple as Basic Scene on http://www.babylonjs-playground.com) it's frame rate always not higher than 40 frames per second. I was expecting it to be 60 fps...

Is there some reason for this or I am missing something?
 

Share this post


Link to post
Share on other sites

Thank you for your quick response KarelAnker!

Indeed, it looks like WebGL uses my integrated Intel Graphics Card:
Unmasked Renderer: ANGLE (Intel® HD Graphics 4000 Direct3D11 vs_5_0 ps_5_0)

How can I switch it to use my nVidia graphics card? (Sorry for such kind of question, but I am newbie in WebGL area).

Share this post


Link to post
Share on other sites

@jsdream it might sound silly but, have you got your display cable plugged into the graphics card or the display port on the motherboard?

I am using laptop. I also tried to set up NVIDIA graphics card to be used for all applications in NVIDIA control panel. Unfortunately, it didn't help.

Share this post


Link to post
Share on other sites

I've just tested in Microsoft Edge browser and it is rendering the same scenes at 64-67 frames per second, while in Chrome, Firefox it is 38-40 frames per second. Why such a big difference?

Share this post


Link to post
Share on other sites

I think that Edge knows which card to use in your case

I have also thought so, but when I visit suggested by KarelAnker url (http://alteredqualia.com/tmp/webgl-maxparams-test/) in Microsoft Edge the Unmasked Renderer field still says Intel® HD Graphics 4000. 

That is why I am a little bit confused. Maybe there is some issue with the script for WebGL parameters detection on the provided page? Or it is really possible that Microsoft Edge performs much better than other browsers, with the same graphics card?

 

You can select NVIDIA from its control panel. Go to the NVIDIA control panel and then 3d settings, and switch the preferred graphics card to NVIDIA's.

 

(tutorial with images here: http://alteredqualia.com/texts/optimus/)

As I have written above I already tried that. When I did it first time there was not any effect at all. Then I read the tutorial (http://alteredqualia.com/texts/optimus/) and updated NVIDIA driver to the latest version available for my graphics card. After that I again changed preferred card in NVIDIA control panel, but now that caused my Chrome browser to freeze any time when I open my Babylon.js scene. 

Share this post


Link to post
Share on other sites

Another strange thing: I found this user's demo http://42.62.1.67/run/ in some sibling topic, and it renders at  60 fps in my Chrome browser. I've noticed there is used Babylon.js 2.3 version. I've also tried to create some simple scene with 2.3 version of Babylon.js myself, but it still renders at 40 fps.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.