Recommended Posts

Hey Babylon citizens!

How are you guys testing on mobile?

Our app crashes on mobile devices. So I was trying to create one of our basic scenes without all our complicated logic and Angular app to be able to test.

Here is a link in case you want to look at https://infinite-springs-90987.herokuapp.com/

It works on android but does not on iPhone so far. It just crashes and reload the page, so I can't see the console. Don't know what's really happening.

I started up a simulator on my mac - and it works fine on all devices from iPhone 4s and later. So I feels like there is a difference between iOS simulator and real device.

Also I've tried browserstack but have not found console output on their real iPhone devices, because they gave me only 10 mins per day free trial :)  And its not working on their cloud iPhones though. I would pay if I can get console output to see what is happening behind the scene....

SO.... How are you guys testing BabylonJS on Mobile? 

Appreciate your help guys!

Share this post


Link to post
Share on other sites

I experienced this many times, and if the code worked on some devices but others, it was generally a server issue. We ended up building our own node.js server, and I haven't located a device a babylon.js scene won't load on. And if it is a recent device and OS, fully supporting WebGL and all extensions, and your server is working without error, than it is generally a device or more common a disticnt browser or browser version.

It appears your server is working alright, and also working with node.js. Looking more now..

 

DB

Share this post


Link to post
Share on other sites

Lots to see here. It's hard to say what the issue might be, but if I we're trying to debug the issue, I would first begin with total compliance - such as power of two textures not above 1024X1024 and a loader for textures to load into your scen before any other operations occur. This will definately increase  some of your loading and performance issues: but I'm sure the Big Guns will be waking up soon to help you fully debug. Welcome to the forum, and you're gonna LOVE this place. :D

DB

Share this post


Link to post
Share on other sites

Agree with @dbawel: try with a smaller scene. No texture first. then slowly add more textures and more mesh

This could be memory issue if it crashes the phone

 

other question: are you using stdMaterial? how many dynamic lights?

 

Please also add the debugLayer in your scene to get visual logs

Share this post


Link to post
Share on other sites

 

@Deltakosh - Do you ever sleep? I don't.

@roman_44 - DK is the "Eye in the Sky", and of couse provides a very straight and complete answer with few words. I've tested on all of my android devices from tablets to Galaxy SM6 and SM7, and your scene loads without problems or adapting the browser using Chrome at least. I can't imagine this isn't a performance issue, and DK went to the point - it's very difficult to get hold of a Tiger by the Tail - as your scene is - in my opinion and limited experience is difficult to troubleshoot. Once buffered it works fine - even on older devices, however, the loading time is massive, and could use a performance optimization to cut your memory and CPU usage dramatically.

OK... loads fine on all my Ipads using Chrome, and the performance is basically the same - so I would either guess it's your browser, or a performance issue based upon limited device and browser testing. Good luck. ;)

DB

Share this post


Link to post
Share on other sites

Hey! Thanks for your help guys!

So let's see what I have so far...

So first of all I figured out that it does not work only on iPhone SAFARI!!! Chrome is ok.  And it finishing loading scene file and then there are about 30 textures and it starts downloading them, and then crash and browser refreshes. So my actually problem is that there is no error in the console. Just refreshes.... 

21 hours ago, Deltakosh said:

Best tool to test on mobile: Vorlon.js 

I looked through this tool. Kinda cool stuff. But somehow it does not work when I put the code to heroku and oopen on my phone. It shows up the device (only if i'm using proxy) but when I click - it only spinning. Just dont have time to figure out ehats the issue there. But I believe it will be the same issue - browser will crash without errors and refresh on iPhone and I wont see anything...

 

21 hours ago, dbawel said:

Lots to see here. It's hard to say what the issue might be, but if I we're trying to debug the issue, I would first begin with total compliance - such as power of two textures not above 1024X1024 and a loader for textures to load into your scen before any other operations occur. This will definately increase  some of your loading and performance issues: but I'm sure the Big Guns will be waking up soon to help you fully debug. Welcome to the forum, and you're gonna LOVE this place. :D

DB

DB, Right now we take out all the textures - just put 3DMAX default ones!! AND BOOM, it works fine!!!!

Hey DB, DK, is there any known issues with amount of textures? Is there any MAX number of meshes with textures?

 

21 hours ago, Deltakosh said:

other question: are you using stdMaterial? how many dynamic lights?

 

Not sure about the materials, but all textures are baked. So it is no dynamic lights on this scene...

21 hours ago, Deltakosh said:

Please also add the debugLayer in your scene to get visual logs

Added. link the same - https://infinite-springs-90987.herokuapp.com/

 

21 hours ago, NasimiAsl said:

important limitation for mobile in webgl is Max Count Of Shader parameters (uniforms, varying )

Dont know what the actually limitation, but if it works an all other browsers, hope it is fine? 

 

21 hours ago, dbawel said:

 

@Deltakosh - Do you ever sleep? I don't.

@roman_44 - DK is the "Eye in the Sky", and of couse provides a very straight and complete answer with few words. I've tested on all of my android devices from tablets to Galaxy SM6 and SM7, and your scene loads without problems or adapting the browser using Chrome at least. I can't imagine this isn't a performance issue, and DK went to the point - it's very difficult to get hold of a Tiger by the Tail - as your scene is - in my opinion and limited experience is difficult to troubleshoot. Once buffered it works fine - even on older devices, however, the loading time is massive, and could use a performance optimization to cut your memory and CPU usage dramatically.

OK... loads fine on all my Ipads using Chrome, and the performance is basically the same - so I would either guess it's your browser, or a performance issue based upon limited device and browser testing. Good luck. ;)

DB

DB, just want to appreciate your time and efforts!!!

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.