Jump to content

GameMaker: Studio Sound Issue in Native Browsers.


Recommended Posts

On 5/25/2016 at 0:41 PM, ivan.popelyshev said:

Have you tried posting this on GameMaker forums ? Its their runtime. Also mobile native browsers are horrible.

Yeah, I tried but currently GameMaker forum is down until the update, but i seen many developers like True Valhalla, using GameMaker Studio and managed to get rid of this problem.

Link to post
Share on other sites
  • 4 months later...

I use GameMaker Studio and had the same issues. 

 

If your issues are anything like mine having a look here would be a good place to start

https://forum.yoyogames.com/index.php?threads/html5-game-no-audio-on-mobile-devices.6124/#post-63208

Just to make sure it's not anything obvious. The audio_play_sound function needs to exist within a left mouse release event (possibly a left mouse pressed event as well, but I find the release events to be more stable)

Have you got test iOS or Android devices? Note that the GM:S devs themselves say sound won't work for iOS using their mini web server. http://gmc.yoyogames.com/index.php?showtopic=606885&p=4487745 but Android devices do work with it.

Does it work in a desktop Chrome browser?

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...