AlbertTJames

MacOS Sierra and Skybox / Cube texture bug

Recommended Posts

Hey,

 

I just upgraded to OSX Sierra and this bit of code does not work anymore on chrome :

/* --- Skybox --- */
  var skyboxObject = BABYLON.Mesh.CreateBox("skyBox", 10000.0, scene);
  var skyboxMaterial = new BABYLON.StandardMaterial("skyBox" + sceneKey, scene);
  skyboxMaterial.backFaceCulling = false;
  skyboxMaterial.reflectionTexture = new BABYLON.CubeTexture(taskObject.ASSETS_FOLDER + "/textures/fantasy/Sky",
    scene, ["_px.png", "_py.png", "_pz.png", "_nx.png", "_ny.png", "_nz.png"]);
  skyboxMaterial.reflectionTexture.coordinatesMode = BABYLON.Texture.SKYBOX_MODE;
  skyboxMaterial.diffuseColor = new BABYLON.Color3(0, 0, 0);
  skyboxMaterial.specularColor = new BABYLON.Color3(0, 0, 0);
  skyboxObject.material = skyboxMaterial;
  skyboxObject.rotation.x = Math.PI;

 

I get this :

Screen Shot 2016-10-04 at 18.02.46.png

 

Only one side of the cube. No error in the console.

 

I will try to get more information on this, I have been swamped these past few days... sorry.

 

This bug is not present in safari.

Share this post


Link to post
Share on other sites

Hello,

I am experiencing this as well... thought I was going crazy until I did a bit of searching and came across this thread.

I'm on macOS Sierra 10.12 (16A323), noticed this bug after I'd updated.

Confirmed my code (similar in function to OP's code) still behaves as expected in Safari (Version 10.0 (12602.1.50.0.10)), however, Chrome (Version 54.0.2840.71 (64-bit)) exhibits the one-side-per-skybox bug.

Related to this, I've tried engine.enableOfflineSupport = false but no change in behaviour.

I've reported this through Chrome's help tools, if there's a better medium please let me know...

Share this post


Link to post
Share on other sites

For anyone coming across this in 2018, the problem is solved in Babylon v3.2.0-alpha0; however, you may need to lower skybox texture sizes to 1024x1024 if they are higher.

I've been able to get this to work without the engine._badOS = true and without noMipMap set to true, using 1024x1024 skybox textures. When using something higher (all 2048x2048, for example), only one side appears.

Share this post


Link to post
Share on other sites
On 1/9/2018 at 3:04 PM, stormwarestudios said:

For anyone coming across this in 2018, the problem is solved in Babylon v3.2.0-alpha0; however, you may need to lower skybox texture sizes to 1024x1024 if they are higher.

I've been able to get this to work without the engine._badOS = true and without noMipMap set to true, using 1024x1024 skybox textures. When using something higher (all 2048x2048, for example), only one side appears.

That’s weird... I use full 8k hdr panorama source images to bake out 2048 x 2048 beautifully HDR to LDR tonemaped png as my skyboxes ...my main pewter has always been Mac... and been running high Sierra... all my skyboxes render no problem and maintain the higest pixel precision possible and again beautifully tone mapped from super hi res hdr

 

let me know if you still having problems with skyboxes 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.