temmink

Particle System and Transparent Background in Chrome

Recommended Posts

Hi All,

I am trying to set up a scene with a particle system but was hoping to render it with a transparent background. When I try in Chrome the particle system is clipped to the mesh in a very rough fashion and has some weird discolouration. 

I have a playground setup here: http://www.babylonjs-playground.com/#1SZQGH#0

Is there anything I can do to get this to work in Chrome? It works perfectly in Firefox or IE.

Any assistance is greatly appreciated.

Thanks

particles.jpg

Share this post


Link to post
Share on other sites

 

8 hours ago, Deltakosh said:

Hello I'm not sure to understand the problem :( I have the same result in chrome and IE

Hi Deltakosh,

Thanks for the reply. I will include some gifs to show what I mean. It appears to be a webkit issue as I am seeing the same behaviour in Safari on Mac.

ie-test.gif
Internet Explorer 11

chrome-test.gif

Chrome (Latest)

Share this post


Link to post
Share on other sites

Hi Deltakosh,

It looks like the issue was hardware acceleration turned off in Chrome. I will check if the same is true in Safari later on. 

I would be nice if I could disable the particle system all together if that was going to be the result of a lack of hardware acceleration, is there a way to do feature detection like that?

Share this post


Link to post
Share on other sites

Unfortunately, we cannot detect hardware acceleration :(

You can still detect fps (https://github.com/BabylonJS/Babylon.js/blob/master/src/babylon.engine.ts#L3018) and based on that turn off particles with scene.particlesEnabled (https://github.com/BabylonJS/Babylon.js/blob/master/src/babylon.scene.ts#L362)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.