JCPalmer

[Solved] HolographicCamera gulping

Recommended Posts

I have added a new file, ../../src/Tools/babylon.tools.pvr.js, to config.json in the extras section right after the dds entry.  Gulp fails a test, but even if I made no changes, HolographicCamera (also in extras) causes the test to fail.  I am really just a user of Gulp, but I imagine the messy death that follows is just a symptom.

This is the output:

C:\Babylon.js\Tools\Gulp (master) (BabylonJS@2.5.0)                                                                     
λ gulp                                                                                                                  
[17:19:20] Using gulpfile C:\Babylon.js\Tools\Gulp\gulpfile.js                                                          
[17:19:20] Starting 'default'...                                                                                        
[17:19:20] Starting 'includeShaders'...                                                                                 
[17:19:20] Finished 'includeShaders' after 6.88 ms                                                                      
[17:19:20] Starting 'shaders'...                                                                                        
[17:19:20] Finished 'shaders' after 1.53 ms                                                                             
[17:19:20] Starting 'buildNoWorker'...                                                                                  
[17:19:20] Tested 38 tests, 38 passes, 0 failures: PASS                                                                 
[17:19:20] Tested 53 tests, 53 passes, 0 failures: PASS                                                                 
[17:19:20] Tested 115 tests, 115 passes, 0 failures: PASS                                                               
[17:19:21] ✗ FAIL: Missing 2 expected files: ../../src/Tools/babylon.tools.pvr.js, ../../src/Cameras/Holographic/babylon
.holographicCamera.js                                                                                                   
[17:19:21] Tested 70 tests, 69 passes, 1 failures: FAIL                                                                 

I see that a JS no MAP is being built, yet I get no error messages.  Is there a 2nd place these entries need to be made?

Share this post


Link to post
Share on other sites

Well, looks like with the latest npm update, the gulp command does not do a typescript compile.  You need to do a gulp typescript now.

Got the syntax in tools.pvr.ts, and changes in engine.ts ironed out, but am seeing errors in math.ts.  Does anyone else get these?

λ gulp typescript                                                                                     
[11:13:38] Using gulpfile C:\Babylon.js\Tools\Gulp\gulpfile.js                                        
[11:13:38] Starting 'typescript'...                                                                   
[11:13:38] Starting 'typescript-compile'...                                                           
..\..\src\Math\babylon.math.ts(242,65): error TS2339: Property 'Random' does not exist on type 'Math'.
..\..\src\Math\babylon.math.ts(242,80): error TS2339: Property 'Random' does not exist on type 'Math'.
..\..\src\Math\babylon.math.ts(242,95): error TS2339: Property 'Random' does not exist on type 'Math'.
[11:13:44] TypeScript: 3 semantic errors                                                              
[11:13:44] TypeScript: emit succeeded (with errors)                                                   
[11:13:45] Finished 'typescript-compile' after 7.76 s                                                 
[11:13:45] Starting 'default'...                                                                      
[11:13:45] Starting 'includeShaders'...                                                               
[11:13:45] Finished 'includeShaders' after 7.28 ms                                                    
[11:13:45] Starting 'shaders'...                                                                      
[11:13:45] Finished 'shaders' after 862 μs                                                            
[11:13:45] Starting 'buildNoWorker'...                                                                
[11:13:46] Tested 38 tests, 38 passes, 0 failures: PASS                                               

 

Share this post


Link to post
Share on other sites

I think the case is wrong for:

public static Random(): Color3 { return new Color3(Math.Random(), Math.Random(), Math.Random()); }

This compiles:

public static Random(): Color3 { return new Color3(Math.random(), Math.random(), Math.random()); }

Expect a separate PR for this very soon, though I did not test it.  No compile error has to be better though.  I could be fiddling with PVR textures for a while.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.