Sign in to follow this  
Politybuilder

Buttons not working on Safari/iOS

Recommended Posts

Aargh! I  have just discovered that I am a complete liar and have NOT used sprite.inputEnabled = true at all. However, I tried it and it still doesn't work. Besides, if that was the problem, surely it would be an issue across browsers rather than just with Safari?

Anyway, button code looks like this:

startButton = game.add.button(300, 300, 'sprites', start, this, 4, 5, 6);

startButton.setFrames(4, 5, 6);

Where 'sprites' is a spritesheet with all the different button images on it and start is the function to be run. Basically NOTHING is happening when I tap on the button - no image change, no function call - nothing.

Share this post


Link to post
Share on other sites

I figured it out. The page that was being loaded was not the page that I thought was being loaded. The page that was being loaded was using Phser version 2.2.2. When I changed it to 2.6.2 everything worked fine.

Thanks for your help though!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.