Sign in to follow this  
koobazaur

Bad Filter/Shader performance ?

Recommended Posts

I recently started experimenting with Filters (shaders) and while it runs well when using a single filter on the world, applying a filter to my sprites seems to be killing performance. Even a simple filter that does nothing but output the color set on just 50 sprites is dropping my framerate from 50 to 18, even when sprites are offscreen.

Is that to be expected? It makes filters virtually unusable unless very sparingly.

Share this post


Link to post
Share on other sites

What version of Phaser are you using? I've had problems with shader performance when using Phaser-ce, as opposed to the latest official build. Using Phaser 2.6.2 (Kore Springs) I am getting consistently high FPS with multiple filters. Might be something to consider.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.