BlackMojito

AA in WebGL2.0

Recommended Posts

Hi All,

As we know that with WebGL1.0, MSAA won't work if we do any post processing stuff. We must use FXAA instead. However FXAA can lead to jaggy edges, 

In WebGL 2.0, multisample render buffer is supported. So my question is whether it is supported now in Babylon? If not do we have plan to support it in the near future?

Thanks

Share this post


Link to post
Share on other sites

Why this does not work on chrome?
Is this related to that webgl 2 problem with Chrome 63? (In Chrome BABYLON stays in webgl 1, in Firefox webgl 2)

Chrome Version 63.0.3239.84 (Official Build) (64-bit)
engine._glVersion =
"WebGL 1.0 (OpenGL ES 2.0 Chromium)"

Firefox Quantum 57.0.2
engine._glVersion =
"WebGL 2.0"

But! All webgl 2 examples work in Chrome 63  like picogl https://tsherif.github.io/picogl.js/ or  webgl 2 samples http://webglsamples.org/WebGL2Samples/#fbo_multisample
Is this some kind of detection error?

Babylon is compiled from latest preview branch.

 

Share this post


Link to post
Share on other sites

@BitOfGold
Deltakosh disabled webGL 2 in the latest babylon version(preview) on chrome 63 because of the bug.
i bet the demos use a version from before it was disabled.

If you use the stable 3.0 it is enabled, https://www.babylonjs-playground.com/indexstable#8IVY6Z#1 

Edit; WebGL 2.0 is enabled again in chrome 63.

Share this post


Link to post
Share on other sites

Hello guys,

I just faced the chrome 63 bug and I saw this thread... Do you have any thread or github issue about it ? Do you already know how to handle it without disabling WebGL 2 ?

Thanks, sorry for feeding a solved topic. :)

Share this post


Link to post
Share on other sites
15 hours ago, Deltakosh said:

The latest version does not turn webgl2 off anymore. We are just turning off uniform buffers (Which is completely transparent for users)

Hi Deltakosh,

It seems that the multisample render target is broken when the format is not unsigned byte. https://www.babylonjs-playground.com/indexstable#8IVY6Z#2

Below is the error message in chrome. 

[.Offscreen-For-WebGL-0x7fdce8166c00]GL ERROR :GL_INVALID_OPERATION : glBlitFramebufferCHROMIUM: src and dst formats differ for color.

 

I am using babylon 3.1.1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.