Sign in to follow this  
paleRider

Strange problem when using highlight layers

Recommended Posts

Hi everybody:

When I use a highlight-layer based effect (fade in-out as Wingnut suggested me here) I obtain the following warnings in the web console:

  • .Offscreen-For-WebGL-00000233101348E0]GL ERROR :GL_INVALID_FRAMEBUFFER_OPERATION : glClear: framebuffer incomplete
  • .Offscreen-For-WebGL-00000233101348E0]GL ERROR :GL_INVALID_FRAMEBUFFER_OPERATION : glDrawElements: framebuffer incomplete
  • .Offscreen-For-WebGL-00000233101348E0]RENDER WARNING: texture bound to texture unit 0 is not renderable. It maybe non-power-of-2 and have incompatible texture filtering

The case is that all my textures are power-of-2 (512x512 px indeed) so I'm very lost here.

Sadly I can't reproduce this behavior on PG, so I only ask for a clue on where to start to find for solving this bug.

Best regards.

P.S. I have running OK other apps using highlight layers. Only for your information, the offending code is using PBR materials.

Share this post


Link to post
Share on other sites

Hiya PR.  Hey, did you recently update to Firefox 58?  If so, I think the core Gods are working on a solve... but...

perhaps... https://www.mozilla.org/en-US/firefox/organizations/

That's Firefox ESR... v 52.6.0.  Revert to it... if you wish, and at your own risk.

I saw those same "framebuffer" errors after I updated to FF 58.  I reverted to ESR, and things started working again.

At minimum, you need to REMOVE all plugins from Firefox 58.  Not just disable.  REMOVE.  Firefox 58 ONLY accepts plugins made with the webExtensions API.  Using the old plugins with FF 58... seems to give highly-unpredictable results.

*shrug*  Just a possibility.  More comments from others... coming soon, likely.

Share this post


Link to post
Share on other sites

Good morning (CET) Wingnut and Deltakosh:

First of all, thank you very much for your help, particularly because the poor info level I can (know) provide on this issue.

About the version of BJS I was using v3.0; changing to v3.1 made the trick.

Best regards.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.