gomgom

Error: WebGL unsupported in this browser - Firefox 83.0, Pixi 5.3.4, ubuntu 20.04.1

Recommended Posts

Hello,

I am facing a problem of which I have seen a few instances on different forums. My pixi app works just fine on Chromium, not under Firefox (I get the "Error: WebGL unsupported in this browser, use "pixi.js-legacy" for fallback canvas2d support." error).

I found this recent Firefox bug report:

https://bugzilla.mozilla.org/show_bug.cgi?id=1675357

I followed the last advice to change the "webgl.disable-fail-if-major-performance-caveat" setting. This fixes the problem, my app works just fine then under Firefox too.
That last post seems to throw the ball back to the Pixi team:

Quote

It sounds like pixi.js is demanding failIfMajorPerformanceCaveat: true. The right thing for us to do is say "sorry but we can't give you WebGL without any major performance caveat", since software rendering is a major performance caveat.
pixi.js SHOULD ultimately fall back to failIfMajorPerformanceCaveat: false/undefined.

Does this give any hint on what is going on? Please note that all pixi examples work just fine on my (recent) PC... Thanks!

Share this post


Link to post
Share on other sites

Thanks for taking the time to answer. I didn't even think of looking for it on the pixi side, I thought this was a setting specific to Firefox. I will play with the settings described on this page: https://pixijs.download/dev/docs/PIXI.settings.html

But does this all mean pixi (or Firefox) is indeed convinced it cannot use WebGl on my PC? I see threads concerning rejected drivers, is this likely due to a driver problem? I have a NVIDIA Corporation TU117GLM [Quadro T1000 Mobile] / Quadro T1000/PCIe/SSE2 graphics card... Trying to understand at what software layer the issue lies: OS, firefox, other..

Thanks again!

Share this post


Link to post
Share on other sites

I have the same problem with firefox 84.0, pixi 5.2.1 and ubuntu 18.04.5 LTS. It was working during long time and one day it stopped. Change to pixi.js-legacy does not help at all.

Edited by flatliner

Share this post


Link to post
Share on other sites

Yes, unfortunately this issue seems to pop up quite randomly 😞 (same thing, my project was working fine for months and then stopped from one day to the next). I've had zero bandwidth to look into it, but I'm surprised there are so few people out there facing the same problem.

I still wonder if this might be due to a driver change, possibly gotten through a background update.

Share this post


Link to post
Share on other sites

What is strange for me to see someone have a problem with chromium. It was working on my desktop and it is still working now.

On 12/16/2020 at 6:55 PM, ivan.popelyshev said:

"failIfMajorPerformanceCaveat: false" can be passed to pixi application, please see Documentation or source code on pixi renderer. Just search this thing in source code.

This settings really fix the problem with firefox. Thank you.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.