Jump to content

Unable to render on a clone of RenderTexture


Recommended Posts

I want to clone RenderTexture, so i can add new details to it with renderer, and also keep unchanged original. But when i try to render something on cloned RenderTexture, it becomes empty.

Is it intended behavior? If so, how is it intended to be done? Make new RenderTexture, render original texture to it and then add details?

Link to post
Share on other sites

clone() exists in Texture, it does not clone the actual surface, its cloning only rects and rotation.

operations like clone() aren't possible without specifying renderer, because RT actually contains links to webgl objects to be copied. Copying a webgl texture is possible with several operations. If you dont know webgl internals, well, the best way is just to render a sprite with that texture to another renderTexture.

However you can request that feature in pixijs github and maybe assign it a bounty.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...