Sign in to follow this  
john0

JavaScript intellisense in Visual Studio 2013 for Web only partially working

Recommended Posts

Hi all. Just started playing around with Phaser and I'm seeing some strange behaviour with JavaScript intellisense in Visual Studio 2013 Express for Web. I followed all the advice I could google, and it's almost working perfectly.. but something to do with being inside or outside of a function seems to be affecting it. I am very new to JavaScript, so I might be missing something, but the following behaviour doesn't make any sense to me:

d1A21.png
(I get one level of intellisense)

mWRrf.png
(but not any more than that)

However, inside of a function it works perfectly...
GrBY2.png
(Intellisense shows me everything)

In a separate file, I get a similar problem, but one function level down...
17pO9.png
(limited here)

MLUGN.png
(but everything here)

Any advice would be much appreciated!

Share this post


Link to post
Share on other sites

I know VS might not be the greatest choice for this, but I'm familiar with it and it's free! And intellisense is also nearly working perfectly! Look at all the lovely intellisense when you're inside the function. It just seems to close, wondered if I was missing anything anyone else had found...

 

Is there a free editor with decent intellisense out there?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.