Jump to content
This forum will be closing down. Please move to the respective dedicated project forums.

Overlap check sets body.touching


ztiromoritz
 Share

Recommended Posts

As I read this correctly: http://www.html5gamedevs.com/topic/2570-bodytouching-always-return-false/
an overlap check in arcade physics should not set the `body.touching` properties.
But this seems not to be correct in version 2.4.4.
If this really is a problem instead of intended behaviour, i could try to provide a simple example.
 

(Currently, I was able to drain down the problem to this call stack

Phaser.Physics.Arcade.separateY    @    phaser.js:81640Phaser.Physics.Arcade.separate    @    phaser.js:81419Phaser.Physics.Arcade.collideSpriteVsSprite    @    phaser.js:81132Phaser.Physics.Arcade.collideSpriteVsGroup    @    phaser.js:81225Phaser.Physics.Arcade.collideHandler    @    phaser.js:81074Phaser.Physics.Arcade.overlap    @    phaser.js:80826

In `seperateY` (as well as in `separateX`) the `overlapOnly` parameter will be ignored and `touching` will be set.)

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...