Jump to content

Sandbox can't load a mesh


Recommended Posts


I'm trying to load .babylon file using sandbox and getting error you can see on the screen shot:

Снимок экрана от 2016-11-22 00:55:00.png


I'm using Blender exporter to get .babylon file. File looks OK and there are no errors or warnings in .log file after export. 

Here is a .babylon file:


Does anyone know what the problem is?  

I'll appreciate any help. 


Link to comment
Share on other sites

@Eva Welcome to the BJS forum :)

I notice from the image above that you are using Blender 2.78 but only version 4.6.1 of the exporter(BBE) .Have you tried the latest version of the exporter (5.1.0)?

I have downloaded your .babylon file, but could you post your .blend file?

cheers, gryff :)

Link to comment
Share on other sites

Hi, gryff !

I downloaded the last exporter version (5.1.0) from https://github.com/BabylonJS/Babylon.js/tree/master/Exporters/Blender . I think that we see version 4.6.1 in browser console because of this https://github.com/BabylonJS/Babylon.js/blob/master/Exporters/Blender/io_export_babylon.py file. It contains string "'version': (4, 6, 1)". But may be I'm wrong .... 

The thing is that I have .dae file that I import into the Blender and after that I export it to .babylon format with exporter. 

Here is .dae file:


There are textures with this file but they are too heavy to represent them here (textures have .tga format). After import it to Blender I get this .blend file:


Thanks for trying to help :-))

Link to comment
Share on other sites

Seems to be something wrong with the dae,
not sure what, i just tried with an export from 3dsmax, same error.

i can load one of my own babylon files just fine in the sandbox,
So it's either the dae file or something very specific the file bugs in the sandbox, mostlikely the file though :)

Link to comment
Share on other sites

I think you're right and .dae file is damaged or something ....

I tried import it with 3dMAX and there was an error associated with "input file". This is sad, model was very nice. I'll try to look for another model.

Thank you very much for your help!

Link to comment
Share on other sites

@Eva Here Eva, try this blend file.


Created by importing the .dae file into Blender 2.76.  The above model in the Sandbox was created by exporting with version with ver 5.0.6 of the exporter.

You don't need the "i/o python" file you posted above. Use this one:


Save that .zip file to your HD. Remove any previous versions of the exporter from Blender. Then install the new version of the exporter using "Install from File" option.and use the .zip file directly. NO need to unzip it - Blender will handle that.

Now activate it and away you go.

I don't have 3DMax - so no idea what the issue might be there.

cheers, gryff:)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...