Jump to content

Phaser gamepad support


Flamel
 Share

Recommended Posts

Hello.

I have been using old dualshock 2(ps2) controller for coding. I bought several new devices and decided to use those for programming.

So, what have changed is that now I am using new xbox one controller, and a surface book. To get new button mapping, I went to phaser's gamepad debug example. It mostly did not detect my device, and sometimes it detect 4 'unknown' gamepad devices (just like in screenshot) which does not even react to different inputs. (Once this state has reached, it stays like that even when I disconnect, or connect my old ps2 controller back. Probably only sure way to go back is reboot.)

I don't know if this is caused from controller or laptop. On this screenshot, one of the devices is called 'surface keyboard,' so I think my laptop has slightly more possibility of this trouble. I would test more to figure this out but I wanted to ask if anyone has experienced this problem or similar ones.

A solution or personal experience (even "mine is working fine!") would be helpful.

ps. I am aware of that html5 gamepad support is experimental. And I am working on this using chrome. (I tried edge but same result anyway)

dfdfsfdsfdfs.PNG

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...