Jump to content
This forum will be closing down. Please move to the respective dedicated project forums.

Suggestion for me.Rendererable.isKinematic name change


Dan K
 Share

Recommended Posts

I think you should change the property isKinematic to "blockEvents" to embody the scope and purpose of this variable.  I know its linked collisions and I suspect that's why it was chosen.  But even if the programmer is looking at the collisions aspect of the Renderable, I think the blockEvents will catch their eye and their mind will consider 'collisionEvents' blocked by the changing of this term.

Link to comment
Share on other sites

thanks for the feedback, but coming from the Unity word, isKinematic is kind of well know as they define the same property. Now admittedly the use of isKinematic has been slightly abused in melonJS to also apply to pointer event as well (if this is what you mean), where it should be limited to physic interactions/motions.

Link to comment
Share on other sites

If it was limited to those physic interactions then I agree... The name seems appropriate... But the fact that it blocked the events surprised me.  However, it was in the documentation so that is on me of course (like there's anyone else to blame...🤣)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...