Jump to content

Rollup HTML5 Audio Doesn't Work?


JonhTheHutt
 Share

Recommended Posts

Hi there! I've been playing around with this template file from photonstorm: https://github.com/photonstorm/phaser3-typescript-project-template, and I've found that if you disable WebAudio in order to use HTML5 Audio and try to load an audio file, this is what happens:

image.thumb.png.9eb4215ea72b262d7c4beb7ae6338449.png

As you can see, the game is created, but the following error occurs in the console:

TypeError: setting getter-only property "dataset" HTML5AudioFile.js:151:12
    load HTML5AudioFile.js:151
    checkLoadQueue LoaderPlugin.js:781
    each Set.js:195
    checkLoadQueue LoaderPlugin.js:767
    start LoaderPlugin.js:717
    bootScene SceneManager.js:492
    start SceneManager.js:1198
    bootQueue SceneManager.js:238
    emit index.js:180
    texturesReady Game.js:398
    emit index.js:201
    updatePending TextureManager.js:153
    emit index.js:182
    onload TextureManager.js:279

I've forked the repository here so you can try it out for yourself: https://github.com/justinro-underscore/phaser3-typescript-project-template

I believe this is an issue with the Rollup configuration, as when I tried using HTML5 Audio with Webpack on another project it worked fine. I was wondering if anyone has any suggestions on how I can rectify this issue?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...