Jump to content

Fire TV gamepad functionality problem


Recommended Posts

Hi there, I have been working on porting a Phaser game onto Amazon's Fire TV and am having problems with getting button and axis input from the fire controllers. The left analog stick shows up as being on axis 0 and 1 (and is fully functional), but the right analog stick does not show up on any axis between 1-100. Similarly, both triggers do not show up on any buttons or axis' between 1-100.


I have tried using Xbox 360 controllers on the Fire TV and the same issues are present. I have also tried creating the APK with both CocoonJS and Crosswalk, with the issue remaining on both.


Has anyone else had any luck with getting the Fire controllers working with Phaser? Or does anyone have any pointers on where I could be going wrong?


Below is the code I am using to display any active buttons or axis

if(this.gamepad.connected){	this.debugTxt.text = "";	for(var i = 0; i<100; i++)	{		if(this.gamepad.axis(i) > 0.1)		{			this.debugTxt.text += " A"+i;		}		if(this.gamepad.getButton(i)!=null)		{			if(this.gamepad.getButton(i).isDown)			this.debugTxt.text += " B"+i;		}	}}

Any help is much appreciated!



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...