turboboing

Internet Explorer 11 WebGL bug

Recommended Posts

Hi,

 

I've been working through the first TypeScript tutorial and I couldn't get it to work using the IIS Express web server with Visual Studio and Internet explorer 11.

It would load the page, but it wouldn't show the Phaser logo.

After a lot of messing around I finally figured out what it is, its a bug in IE 11 to do with WebGL.

 

I set Phaser.AUTO and started it up in IE 11 and in the output log it says "WEBGL11258: Temporarily switching to software rendering to display webGL content".

If I force it to Phaser.CANVAS it worked fine.

 

There's a bug logged with Microsoft

http://connect.microsoft.com/IE/feedback/details/805206/webgl-only-doing-software-rendering

 

My question is, shouldn't Phaser detect this and fallback to canvas?

 

 

Tim.

 

 

Share this post


Link to post
Share on other sites

The issue is how Pixi handles alpha within WebGL I believe. They've not yet fixed it, but it's just down to a matter of time. I didn't want to add a blanket kill-switch "if IE11 use canvas" as there is no knowing at which point it may be resolved, and from which end, although I may consider adding one in 1.1.4 if there's no sign of a solution coming from the Pixi camp soon.

Share this post


Link to post
Share on other sites

Thanks Rich.

 

Its bloody annoying that IE 11 was supposed to be the webgl breakthrough, and you have an annoying issue like this.

 

By the way, I tried the runpixierun pixi.js demo on my laptop, it runs but it reverts to software, If I force IE to version 10 it reverts to canvas and runs much faster.

 

I think like you said its probably something Pixi.js is doing that IE11 think it can't do and reverts to software render.

Share this post


Link to post
Share on other sites

I am (still) using Phaser 1.1.3 an I have the same problem with WebGL.

 

FYI: Here is the JavaScript I use to detect IE11:

http://stackoverflow.com/questions/19999388/jquery-check-if-user-is-using-ie/21712356#21712356

 

Setting the renderer to Phaser.CANVAS for IE11 is the only solution I found, as of today.

 

edit: I have to change to canvas for Windows Phone 7 and 8, too.

Share this post


Link to post
Share on other sites

I came across this one today.

 

The game appears fine on IE11 if the body background is black, but is completely invisible if it's white. If you set it to a color like red, you can see red blending through the game graphics.

 

I suppose the best answer is still to detect for IE 11 and switch to canvas?

Share this post


Link to post
Share on other sites

Hi guys, i have a similar issue with IE. It's not regarding in particular WebGL rendering but Canvas Rendering. I have no rendering at all both with Canvas and WebGL, i only see the canvas completly black. The strange things is that if i open the debug tools (F12) and reload the page everything works fine. No one had this issue? I am using  Fullscreen Template with Phaser 1.1.6.

Share this post


Link to post
Share on other sites

Hello,

I am also facing the problem with WebGL for three.js in IE. The error it is showing is webgl content is taking too long to render on your gpu so currently switching to software rendering. In https://stackoverflow.com/questions/42092214/webgl-rendering-time-limit-internet-explorer-11 this site they are saying that make your calls less. But I need those models runtime at a time. How to tackle this problem. Can anybody please answer, if faced the same.  I have WebGL 77 version and IE 11. Thank you. 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.