rich

Phaser 3 Beta 1 Released

Recommended Posts

I'm glad to announce that Phaser 3 Beta 1 is now available.

There is a Getting Started guide:  http://phaser.io/phaser3/gettingstarted which details how to download it and get up and running.

Once you've got it running I'd urge you to check out the Phaser 3 Examples. Click 'Edit' on any demo to see the code and learn from it! There are no docs for Beta 1 as we've been delayed by various issues, but they will start to arrive in Beta 2 in a few weeks time. Nearly all examples up on the Labs will run under Beta 1 as I spent a good while tidying them up. You will still find some that don't run but they should be in the minority now.

Any questions - post here!

Cheers,

Rich

Share this post


Link to post
Share on other sites

What will happen to the forums (and discord/slack) when Phaser 3 gets closer to release? I'm already seeing discussions pop up about Phaser 3 here and there. Separate subforums/channels for v2.x and v3?

What is it that you aren't a fan of with the v2 docs? I think they are great.

What plugins are planned for after release?

Share this post


Link to post
Share on other sites

This forum is for discussing beta releases. When v3 goes stable I will either close this off or use it for 3.1, 3.2, etc betas. The main forum will become the correct place to discuss it. Slack / Discord is low volume enough that no sub-channels are needed. I have no intention of fragmenting the community after release, everything will just be 'phaser' and it'll be up to you to tell us which version yo are talking about in your posts / chat. V3 will just be a continuation of the versioning. The only difference will be on the web site where I'll split things like the docs and examples up into versions.

I have no plans for plugins post-release yet. I will be focusing on learning materials first. There's plenty of opportunity for plugins, but there are none on the drawing board so to speak.

Share this post


Link to post
Share on other sites

 @rich Great job you are doing.
I tried loading the demos but keep getting this issue across the different demos.
 

GamepadManager.js:123 Uncaught TypeError: Cannot read property 'index' of undefined
BaseLoader.js:268 default - Loader Complete. Loaded: 1 Failed: 0

 

Share this post


Link to post
Share on other sites
1 hour ago, Adibas03 said:

 @rich Great job you are doing.
I tried loading the demos but keep getting this issue across the different demos.
 


GamepadManager.js:123 Uncaught TypeError: Cannot read property 'index' of undefined
BaseLoader.js:268 default - Loader Complete. Loaded: 1 Failed: 0

 

So, i was able to track down the culprit,
Needless to say, it was not a code error

the Gamepads webpack has a function

 `L#104 : refreshPads: function (pads)`

and a check
`L#118 : if (pad === null)`
which resolves to false as the actual list was undefined. 

GamepadList {0: undefined, 1: undefined, 2: undefined, 3: undefined, length: 4}

 

---Update--

Updating this line fixes it
https://github.com/photonstorm/phaser/blob/v3.0.0-beta.1/v3/src/input/gamepad/GamepadManager.js#L117
 

if(pad === null || typeof pad == 'undefined')

 

Share this post


Link to post
Share on other sites

Great work as always! Two quick questions:

1. Will you add this.load.tilemap or should we user this.load.json / this.load.text / this.load.xml?

2. Will Impact physics replace Arcade physics or will it be two separate things?

Share this post


Link to post
Share on other sites

@Adibas03 thanks for the report - the docs say it should return null, but you're right, it's undefined sometimes too damn it! I've updated this and fixed it in the repo, but beta 1 will still have the error. You could either pull the repo and build yourself a version, or add this line to the game config of any example to disable gamepad input (which will stop the error triggering at all)

var config = {
    type: Phaser.WEBGL,
    parent: 'phaser-example',
    width: 800,
    height: 600,
    input: {
        gamepad: false
    },
    scene: {
        preload: preload,
        create: create,
        update: update
    }
};

 

Share this post


Link to post
Share on other sites

@richNo wonder that you're a bit behind after everything. Plus it isn't normal to be on schedule with stuff like this anyway no matter how well you plan. I got an sudden urge to try to make a basic platformer demo to share, but I guess I'll need to be a bit more patient. :-)

Share this post


Link to post
Share on other sites

@rich Thanks, I'll check it out. I had an idea to recreate 1-1 of Super Mario Bros just to see how far I would get.

I just bumped Phaser 3 to Beta 2 in the bootstrap project I've been posting about in the forum and got the following error from webpack:

ERROR in ./node_modules/phaser/src/camera/local/CameraManager.js
Module not found: Error: Can't resolve './inc/AddsmoothedKeyControl' in '/home/niklas/projekt/phaser3-es6-webpack/node_modules/phaser/src/camera/local'
 @ ./node_modules/phaser/src/camera/local/CameraManager.js 37:27-65
 @ ./node_modules/phaser/src/scene/local/Systems.js
 @ ./node_modules/phaser/src/scene/local/Scene.js
 @ ./node_modules/phaser/src/phaser.js
 @ multi phaser

I haven't tried to solve it but it appeared just by switching from Beta 1 so I thought you might want to know.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.