Sign in to follow this  
MadeByJawns

Babylon not loading properly on Chrome - Ubuntu

Recommended Posts

Hey peeps,

Was wondering if anyone else has this bug or if it's just my machine.
On Ubuntu 16.04 - Chrome (updated to 65.0.3325.181 (64-bit)) most babylon scenes don't load properly, for example, from homepage https://www.babylonjs-playground.com/frame.html#PSR2ZX#10 

At first, I thought because it mentioned materials/shader in the console error, maybe it was to do with my mesh or pbr materials and too many uniforms but when I changed that stuff to the minimum, it still errors. This is shown if you load the "Basic scene" on playground http://www.babylonjs-playground.com/#BHNVUE it still has that long list of console errors.

Note that in Ubuntu firefox our scene works fine, have also tested on Windows - edge, chrome, firefox and Mac - safari, chrome, firefox, babylon seems to load everything okay without error.

I noticed this last year but just used firefox for dev in time being as kind of assumed it would be fixed in 3.2 but we just updated to 3.2 today and see it's still an issue, please let me know if it is known issue, as business wise it doesn't affect too much for us, just my own personal workflow, would like to be able to use chrome lol.

Thanks in advance!

Ubuntu-Chrome-Error.png

Share this post


Link to post
Share on other sites

Damn  :( Thanks for checking it out though.

Not sure if this can help to debug, but yesterday when flicking through the playground scenes, I found that it only happens with scenes that have meshes. All the other ones seem work fine.

For instance, this sprite one works completely fine https://www.babylonjs-playground.com/?8 with 0 console errors.

But as soon as there is a mesh of any kind, the mesh will just not appear and console will have that huge list of errors :S

As shown in this particle demo which works fine apart from the cube and plane not being there and the console error https://www.babylonjs-playground.com/?12

Sorry, I wish I could give more info / debug myself.

Share this post


Link to post
Share on other sites

Omg even though I updated many times before, it turns out it was still using the legacy binary driver inside additional Ubuntu driver settings, then I couldn't change it, quick google and found out had to change it to "Download from main server" to be able to change it from legacy to the normal one. Doh. Sorry about that. I'm still a linux nub.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.