Jump to content

CocoonJS new Launcher Version - Game won't start - no errors in console.


Recommended Posts

on the iPad Air I've got the previous version of the CocoonJS launcher, everything works fine.


On my other iPad I've got the new version (Updated a few days ago). The same game won't show up in the new Version. It shows FPS, but a black screen, there are also no errors in the console...

I do not know what this is causing? any suggestions, what is different in the new launcher?




Game won't show up in canvas+, webview+, webview.

canvas+ loads the fps up to 60... that's all, webview+ and webview are doing nothing... still no errors in the console... before the update everything works fine. And it is not only with one game, another I've been developing : sam effect :/

Edited by Sam
Link to comment
Share on other sites

looks like I'm not the only one: after searching a while found this post on this site:

has anyone else experienced this problem?
still I'm testing with 4 devices... and all behave the same.
I tried different gamecodes... still nothing shows up...

even a nearly empty phaser project with only load, create and update and 1 tile won't load..

Link to comment
Share on other sites

the problem was figured out by ludei here is the answer:


We found the root of the problem. We are currently fixing it but it will take some time, so I will try to explain how to use a provisional workaround until we can update the launcher at the stores.

Phaser, by default, checks the following code:

if (document.readyState === 'complete' || document.readyState === 'interactive')


        window.setTimeout(this.onBoot, 0);


    else if(typeof window.cordova !== "undefined")


        document.addEventListener('deviceready', this.onBoot, false);




        document.addEventListener('DOMContentLoaded', this.onBoot, false);

        window.addEventListener('load', this.onBoot, false);


Normally, the default branch for cocoonJS is the third one, but now we have included Cordova in the Launcher, so it takes the second one instead. That is why it is not working as it should, because it recognizes the window.cordova.

So, meanwhile we fix this, what you can do is to set window.cordova to null just before the var game:

window.cordova = null;

var game = new Phaser.Game(....);

Sorry for the inconvenience. We will let you know when the launcher is updated.


Link to comment
Share on other sites

  • 2 weeks later...

There are news with a response of Marta from CocoonJS:





As the real problem is solved and the only problem that remains is that it takes time to upload the launcher to the store, we have decided to share a provisional link that contains the launcher for Android with the fix. 
Android: https://www.dropbox.com/s/do4iepidjc8d0am/cocoonjslauncher-beta-release.apk?dl=0
For iOS this is more complicated, because we can't provide you anything else than a custom launcher at the moment. But you can compile a custom launcher on your own for testing, so there is no point on doing it.

Hope this helps until we can update the launcher.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...