Jump to content

sprites fail to render on some (older) devices


wizzard262
 Share

Recommended Posts

sorry I've searched for the answer for this, but found none.

I've created my game : http://www.battleofhoth.com

and tested in on all devices I've got to hand so far.

 

  • PC works great
  • Tesco HUDL2 works great
  • HTC Desire it just about playable in Android default browser, but slow, no sound, pleasant surprise
  • iphone 3 I get small black squares with green diagonal through them for sprites
    but images I've added to the game render correctly (see attachment)
  • Nexus 7 1st gen (I downloaded Android 5, keen to see it, but it really slows it down)
    I get black void squares the correct size for sprites
    but images I've added to the game render correctly (see attachment) and tween
    The game does work when you jab around at it

I suspect this is just the devices being too old.

The iPhone 3 I'm surprised worked as well as it did,

but the Nexus 7 I thought would work.

 

Is there a list of devices that do and don't support Phaser ?

(Would that just be a list of devices that support either Canvas or Web GL?)

 

Have I possibly coded something incorrectly that I could fix ?

 

Thanks

Steve

 

 

post-11925-0-78989800-1419981351_thumb.j

post-11925-0-28718100-1419981353_thumb.j

Link to comment
Share on other sites

perfect thanks !

I changed Phaser.AUTO to Phaser.CANVAS and it worked on the Nexus 7 1st Gen

So I guess it thinks it can do web GL,tries to, and does it badly

Strange as that is the newest Android Lollipop 5, maybe its a hardware thing.

I've had only 1 other thing fail on it. (Gravity, game that goes with the film) 

 

I still get the same problem on iPhone 3 but not bothered about supporting that.

I think that may be a different issue, its what happened on desktop when the image file was missing so its like its not finding the image files.

Link to comment
Share on other sites

iOS6 (hell even iOS3) was and still is perfectly fine for almost all Canvas needs (its the other APIs we like to use that it doesn't support ex. performance.now, requestAnimationFrame ). You just need to track down what is causing the image to not load. If you go into Settings / Safari / Developer you can turn on the console and it should spit out any warnings or errors for you. It won't be the most detailed but it might be enough to figure out what you need to check in to.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...